Question Asus TUF Gaming B660M Plus D4 audio problem (bass management not available)

Simivok

Commendable
Dec 26, 2020
6
0
1,510
Hi everyone,

Today I have bought the mentioned motherboard. Everything works fine, except I am unable to get the LFE sound work.
I have an analog Genius 5.1 speaker set, which connects to the pc with a green and an orange jack (for the subwoofer).
I have installed the Realtek driver from the motherboard's website. I did select the 5.1 configuration, ticked the subwoofer in (and when I test the subwoofer it has got sound), however
there should be an option: enable bass management but I dont have that option. Therefore there is no bass at all, for instance when I am playing music.

I tried to reinstall the driver, and i couldnt find any older driver for instance the sound driver for a B560 motherboard is not compatible...

Please help
 

Lutfij

Titan
Moderator
Did you check and see if the connectors are all the way into their respective ports? Might want to include images to how you've tethered the speakers to the sound card, meaning we'll be seeing two ends, one for the input on the speaker set and one for the outputs behind the motherboard. Please mention the model for your Genius branded speaker set as well.

Might want to also see what your current BIOS version is for the motherboard. When installing any driver, you're advised to install them in an elevated command, i.e, Right click installer>Run as Administrator.

Today I have bought the mentioned motherboard.
+
i couldnt find any older driver for instance the sound driver for a B560 motherboard is not compatible
Did you simply migrate your older OS drive onto the new motherboard? If so, that's your problem altogether. You should reinstall the OS after a motherboard change/platform swap.
 

Simivok

Commendable
Dec 26, 2020
6
0
1,510
Hi, thank you for the answer.

Checked both ends, fine.
Type of speaker set: Genius SW-5.1
Bios version: 1620, 8/13/2022

I have installed this driver with admin rights.
Its a freshly installed Windows 10 Pro 22H2 with updates installed
Installed every driver.

There is an image of the issue: https://drive.google.com/file/d/1ea0PbnyaDhct9r-d6Rz9sMrMFfq7MlhR/view?usp=sharing - insert image not working sorry
On the bottom there should be an option called bass management

On the classic Sound options interface there is no Enhancement tab...

Theoretically, since this motherboard equipped with several audio jacks it must support it, right?

Do you think BIOS update should resolve the problem? I dont like updating bios'

What should I do?
Thank you in advance