Question ASUS TUF Gaming X570-Plus WiFi, S-AM4. I just built my pc, but it wont power on.

Nov 26, 2021
9
0
10
0
It just won't power on. At first I thought I wrongly installed the front panel power switch. But no it wasn't that. Then I tried starting it up by touching the pins with my screwdriver. Nothing. The motherboard does light up, showing it gets power when I turn on the PSU. So I don't think it's dead. I've also tried removing all my ram and just leaving one left in the second slot and try powering on. But no. Any help would be greatly appreciated.

CASE: Phanteks Torrent
CPU: Ryzen 9 5900x
AIO: Kraken Z73
PSU: EVGA B3 850W modular 80+
RAM: Corsair Dominator 4×8 32GB DDR4 @3200
GPU: Gainward RTX 3090 Phoenix (unplugged)
 
Last edited:

jp182

Distinguished
Apr 11, 2003
105
0
18,680
0
When you say it doesn't turn on; are you not seeing anything on your screen? Typically when that has happened to me, the graphics card isn't properly seated or the cable isn't completely connected.
 
Nov 26, 2021
9
0
10
0
When you say it doesn't turn on; are you not seeing anything on your screen? Typically when that has happened to me, the graphics card isn't properly seated or the cable isn't completely connected.
Hello I mean it won't power on. I should be clearer when I wrote that my apologies.
 

steveb1976

Prominent
Oct 4, 2020
65
6
545
4
you say your GPU is "unplugged" what do you mean,if you dont have your graphics card plugged in, you wont get the bootup screen on your monitor. , also did you flash the bios with an update. .

if you get fans spinning then the board is getting power. i would also suggest taking the memory out slot 2, and tying it in slots 1,3 and 4 to see if you get boot from that. some boards are fussy.
 

ASK THE COMMUNITY

TRENDING THREADS