Question ASUS TUF Z590 Plus WiFi - - - - No POST and No QLED lights ?

Jan 22, 2023
Built a PC for a friend for Christmas, worked for about a month but a few days ago the PC shut off and won't post anymore. No mobo lights or beeps indicating a problem. All fans spin and RGB turns on, but no signal is detected.

MSI z590, swapped to a ASUS TUF z590 Plus Wifi
i3 10100f
Corsair Vengeance 2x 16 gb 3200mhz
XFX RX 590
M.2 ssd
2x 850w Thermaltake Toughpower GF1

Things I've tried:
-Multiple HDMI/DVI cables in each GPU slot.
-Multiple monitors
-Clearing CMOS
-Removing CMOS battery
-Different graphics card
-Other PCI slot
-One stick of ram
-Every ram slot
-Reseated CPU
-New PSU
-New mobo
-Ram from other computer
-Ram in another computer (it worked)
-GPU in another computer (it worked)
-Every m.2 slot
-Removing my m.2
-Disassembling and rebuilding the entire PC

Only thing I haven't tried that I can think of is using another CPU that is compatible with the motherboard, but I don't have another CPU to try.

Any help is appreciated.