Question ASUS TUFF B450 not powering on

loadyo

Prominent
May 13, 2019
24
3
515
0
i bought this board with a ryzen AM4 processor for it (it is compatible) and RAM to fit, it is replacing a working board in my server that had served me well but i wanted to put the 9 drives i had running onto a raid card that uses those nice thin sata cables, it basically runs 8 of the drives and plugs into the PCIe socket, i put it all in and powered it on and everything was fine so i closed the case and put it under my desk.

When i went to switch it on it wouldnt start, only the leds lights on the board were on but the cpu fan does not spin nor does the psu power up so I took everything out of the case and benched it, removed everything except the CPU and tried to power on by shorting the power pins, still nothing.

i then plugged in the old board to the PSU and that started up fine so i assumed the board had died, i got it RMA'd through asus and when the new one arrived it was still the same so i then had the CPU RMA'd by AMD, this arrived today and i placed it in the board and still it wont power on, not really sure what i should look to next, dont really want to buy a new PSU if this one still worked the former board.

Is it possible that the PSU doesnt work with this board or has semi failed for use in it? I have had the main components changed for new and am still in the same posistion, i cant afford to buy new kit and have already RMA'd the board and CPU, any advice please ?

I did a quick google search and there seemed to be quite a few threads regarding this board not powering on...strasnge thing though it worked for ten minutes the first time i installed everything.
 

ASK THE COMMUNITY

TRENDING THREADS