Question ASUS VG278QR multi-monitor setup "resets on wake" problem

rasmasyean

Distinguished
Mar 15, 2008
225
1
18,695
4
I just bought 3 of these.
ASUS VG278QR
https://www.newegg.com/p/N82E16824236994?Item=N82E16824236994

When I come back after it blanks or computer goes to sleep, all windows crunch up into the main desktop. The other 2 desktops are empty and you need to reformat all the positions of your windows that were once there.

I tried to find a setting but couldn't figure it out.
I connected my 3 old monitors and it doesn't do this.
ASUS VG248QE

Anyone have any clues as to how to fix this?
I'm thinking of returning all of them as this is unacceptable and sounds like a hardware compatibility issue. But hopefully you guys can save me the hassle. :)
 

QwerkyPengwen

Splendid
Ambassador
Provide the following information:
What GPU do you have?
How are you connecting all three monitors? (What cables and connection types are you using)
Are all three plugged into the GPU or is one or more of them plugged into the motherboard? (assuming you have integrated graphics)
Do you have power saving modes turned on for any of the monitors in their built in settings?
Do you have any power plan options set to turn off any of your displays in Windows power plan settings?
 

QwerkyPengwen

Splendid
Ambassador
Is this a clean install of Windows or no?
Is it fully up to date?
Have you checked to make sure there isn't something wrong in Nvidia control panel?
Make sure you are using the latest Nvidia drivers.
Try doing a clean install of drivers using DDU in safe mode to uninstall them and then installing freshly downloaded drivers.

Google for DDU and get it from guru3d website.

To get into safe mode, go to start menu, go to power, then hold shift and click on restart. Keep holding shift until you get to the recovery screen.

Go to troubleshoot and advanced then to startup options and restart then select safe mode with networking.

Once in safe mode, use DDU to uninstall drivers then download and install latest drivers from geforce website while in safe mode.

After drivers are installed restart PC and test again.
 

rasmasyean

Distinguished
Mar 15, 2008
225
1
18,695
4
It was a clean install/update of Windows on a brand new motherboard and CPU.

I just swapped in a different older computer and it has the same issue. Whereas, this older computer was previous used with my old monitors and never experienced such issue. As a matter of fact, I never experienced this issue before with any assortment of Windows / GPU / motherboard / CPU / driver combo. Not even when I turn off a monitor iirc, whereas turning off the new monitor bumps out the windows on it.

What it "looks" like it's doing is losing the monitors for a bit and re-establishing the extra desktops.
Perhaps the monitor handshake response is so slow/paused/glitched such that Windows assumes you no longer have it connected and defaults to 1 desktop?
I can even bump windows off the primary desktop just by turning off and on the primary monitor.
 

QwerkyPengwen

Splendid
Ambassador
I honestly don't know why it's doing this if it's a fresh clean install, and everything is fairly bare bones.
Windows shouldn't be bumping anything unless you basically disconnect the monitor, which is what it sounds like Windows thinks is happening.

You say this happens on only two occasions:
#1. if you turn off one of the monitors with it's power button (which shouldn't cause this to happen)
#2. when the computer goes to sleep and wakes up

After doing a quick Google search to see if other people have had this issue I came across this as the second result

Go into Windows sound settings, and disable all of your HDMI/DP Nvidia sound device options.
 

rasmasyean

Distinguished
Mar 15, 2008
225
1
18,695
4
Also:
#3. if screen goes to sleep and wakes up while the computer is still on.

The "disable sound" trick didn't work. I also tried to change the sound source on the monitor from Displayport to Line In.

Also, when I connected the old computer to these new monitors, I didn't plug the speakers into the motherboard so it seemed like it defaulted to some monitor. But it still bumps the windows. So that that thread you found might be a different issue.
 

rasmasyean

Distinguished
Mar 15, 2008
225
1
18,695
4
Aha...I think I caught something that may offer a clue.

The monitor sound source reverts back to DisplayPort (from Line In) after it wakes or I power cycle it.
Does this mean anything?
 

QwerkyPengwen

Splendid
Ambassador
Looking further into this on Google, this is an issue related to Windows and how it handles displays.
Essentially, when using DP for example as you are, Windows sends a signal to the monitor to go to sleep whenever it goes to sleep or turns off, or when you have turn off monitor options enabled.
The problem happens when the PC wakes up, and gets going faster than the monitors causing a scaling/sizing issue that forces everything to go to the main display since that is the first one to wake up.

Basically we have to tell Windows to never turn off display.
Go into monitor settings and tell it to never turn off but only go into standby mode.
and best of all, just don't use Windows sleep mode, since this pretty much causes the issue.
I suggest if you want something akin to sleep mode, you enable hibernation option in windows power plan settings.

since resuming from hibernate will make your PC boot the BIOS post screen and load up Windows from a saved state, it will give your monitors a chance to initialize so that when it gets to the part where you load into the desktop, the monitors are on and Windows should put everything back where it was.

I personally don't ever use sleep on my PC and this might be why I never experience the issue.
I do have the option for turning off my monitors after a few hours of inactivity enabled, and it hasn't caused an issue for me but I have different monitors than you (one is a Dell G-Sync the other is an LG ultrawide)
I usually don't ever do hibernate either, a lot of times, I either just leave my PC running, or when I'm done with it, I shut it down.
 
Reactions: rasmasyean

rasmasyean

Distinguished
Mar 15, 2008
225
1
18,695
4
I suppose this might be caused by new visual features (aka useless gaming marketing bloat) that takes time to boot up in the monitor?

Anyways, the Hibernation seems to work and take 3 seconds more (13 vs 10 seconds) to start up.
One thing I noticed was there wasn't any noticeable difference between allowing "Hybrid Sleep" and not.

I only filled up like 5 of 64 GB of RAM in my test. Will it make a difference if this was like 60 GB of RAM in a hypothetical future where I don't restart my computer for a long time?
 
Last edited:

QwerkyPengwen

Splendid
Ambassador
Not sure. Never heard of hybrid sleep and don't know how it works and have no personal experience with it.

Glad that hibernate works for you as an alternative to sleep (since it sounds like you have an SSD) and has fixed the issue meaning that the issue is definitely caused by the monitors not waking fast enough.
 

rasmasyean

Distinguished
Mar 15, 2008
225
1
18,695
4
Yeah, that was prime technical intuition on your part. Thanks.

This is my M2 thing, I guess it helps that it's faster.
https://www.newegg.com/hp-ex950-2tb/p/N82E16820326181?Item=N82E16820326181

Hybrid Sleep seems like "Sleep with Drive Backup" from what I read briefly. So one would suppose it would take longer than Sleep to shut down, but be just as fast to wake up since RAM is still there if not unpowered. But Hybrid sleep also works, presumably since it doesn't do what I supposed it would. I could be misunderstanding something though.
 

ASK THE COMMUNITY

TRENDING THREADS