Asus X99 Deluxe MOBO/Logitech Headset problems

aldrickexgladius

Prominent
Feb 4, 2018
2
0
510
0
I have a Logitech G633 headset(everything updated) plugged into a Asus X99 Deluxe mobo(usb2.0 port in back panel. drivers, chipset, Bios, everything is updated) but the mic is not working. im geting feedback when i choose the option to listen, but apps like Discord, TeamSpeak, Steam, etc. are not getting my voice.
ive been trying to get this working for 3 days and Asus nor Logitech dont seem to want to help.

i also tried plugging in my old Corsair Voids just to make sure, same thing.
ii let my neighbor plug them in to his Xbox(thats all he has) and the mic worked for him on both headsets.

this is starting to piss me off beyond belief. i cant talk to anybody while playing EFT, SCUM, blah, blah, blah.

somebody please help

Corsair Crystal 570X
Intel i7 5930k 4.1Ghz - NZXT X42 AIO
Asus X99 Deluxe
Corsair 16Gb DDR4 28000
Asus Strix 980ti - NZXT X52 AIO
WD 1Tb Blue - Main Drive, OS, Games and Random Programs
WD 2Tb Black - Steam
Logitech 633, 502, and 410
Saitek X52 HOTAS
BenQ 24" RL2460H 1920x1080 (gaming)
HP 19" w185e 1366x768 ("work")
 

Similar threads


ASK THE COMMUNITY