Info ASUS z170-AR motherboard bios update problems and reverting to older bios - results and work around

RockstarBruski

Distinguished
Sep 15, 2013
2
0
18,510
0
Today I updated my older ASUS Z170-AR motherboard bios from 1902 to 3801 and it hosed it. I just spent 8 hours with the same problem that was described in an older thread but it didn't have a valid answer. I replied to that thread with my solution but it looks like an admin deleted my reply and then locked the thread for no more replies. Hopefully this new thread will not get deleted or locked as I'm just trying to share a warning and work around from what I went through.

After updating my bios from 1902 to 3801 I was able to boot consistently into BIOS nor windows. Sometimes I could get to boot to bios about every 1 in 5 times of booting and then windows but it was very hit or miss. Prior to me updating from v1902 to 3801 my computer was working flawlessly.

The only reason I updated is sometimes from power up it would go to bios and then I'd have to exit bios and it would then go into windows. It was a slight annoyance and I thought why not update the bios and see if it fixes that problem. Bad choice! I ended up trying every bios from 3007 to 3801 with various settings and removed all peripherals, etc and still no joy.

I tried to revert back to 1902 but it said invalid bios for this motherboard. Same with v2202. After 8 hours of trying and hunting I found a great video on youtube of a guy showing how to manually rewrite the bios to whatever version I wanted. I chose my 1902 version and downloaded the bios file from ASUS and followed the youtube instructions and it worked perfectly restoring the bios to v1902.

Here's the links and I know that this is an old motherboard now (5 or more years) but in case others are running this motherboard still and run into the same problem I hope these links help you. Hopefully you don't try to update your bios in the first place as it seems to be a problem on this particular motherboard for some people.

"I might be a geek" youtube DIY video on how to revert to older bios
View: https://www.youtube.com/watch?v=DwJS8-GTgRU

Note - that I used Rufus v 3.10 to create my bootdisk as the video had an older version link for you to download.

asus site to download bios https://www.asus.com/me-en/supportonly/Z170-AR/HelpDesk_BIOS/

I hope this helps some people! :)
 
Last edited:

ASK THE COMMUNITY

TRENDING THREADS