Question ASUS Z170 SABERTOOTH MARK 1 - ORANGE POWER LED (PC NOT STARTING)

Jan 13, 2021
6
0
10
0
Hi All,

I have the above motherboard, everything is connected but when I turn it on just the orange LED marked PWR and nothing else comes on (no fans or RGB etc.) -

I have taken out the GPU and one stick of RAM so far but still nothing.

Annoying because it has LEDs to show which component is causing an issue and none of them show up, just the orange power LED.

The 24 pin & 8 pin power ATX power connections are in just fine.

What else cold it be? Might try the CPU next.

Any help would be greatly appreciated
 
Jan 13, 2021
6
0
10
0
was this working before?
full system spec?
I bought it from a friend and he was using it for a good couple eyars so was working fine but this is my first build.

Full system spec:
Intel i7 6700k
Corsair vengeance RGB Pro 16GB (2x8GB)
Cooler Master Hyper 212 RGB Black edition CPU cooler
Cooler Master Silent Pro 700W PSU
Geforce GTX 1080 GPU
512GB M2 NVME SSD
1TB SATA HDD
Phanteks Eclipse 400A case
 
Jan 13, 2021
6
0
10
0
Hi All,

So this is my first PC build, everything is in and fine but when I turn the PC on, the DRAM LED on the motherboard lights up orange BUT the RGB on both the RAM lights up?

Even with one stick of RAM in the recommended A2 & B2 slots one at a time the LED still stays on? I have even tried pressing the MEM OK! button but the issue still persists.

Any ideas? will the RAM still work okay if I try A1 & B1 DIMM slots and any idea what the issue could be?
 
Jan 13, 2021
6
0
10
0
when u power on pc for first time, it will run several tests for your ram, that can take few minutes
its called memory training

otherwise post your full system specs including ram product number
So I let it run for a few minutes but still nothing changed.

Full system specs:
ASUS Z170 SABERTOOTH MARK 1
Intel i7 6700k
Cooler master Silent Pro 700W
Cooler Master Hyper 212 RGB Black edition
RAM is 2 x8GB Corsair Vengeance RGB Pro 3200MHz DDR4 (where would I find product number?)
Geforce GTX 1080 (not hooked up yet as it blocks all the error Leds)
Adata XPG SX8200 Pro SSD 512GB
Seagate Barracuda 1TB
 
Last edited by a moderator:

ASK THE COMMUNITY

TRENDING THREADS