Question Asus Z490 F-Gaming won't boot

Dec 4, 2020
2
1
10
0
Hi All, I'm having an Asus Z490 that won't boot. Strix lights of the board is working fine. Strange thing is that I don't get any of the Q-Led or any beep. When power button is pressed, all fans start but I don't get other response from the board.

Build is:
ASUS Z490 F-Gaming
Intel I7 10700F
2x16G Ballistix DD4
PSU Sentey EPP750-HM 80 plus bronze

Things I've tested:
  • tested another the psu, not change.
  • removed everthing: hard drivers, memory, cpu, no change.
  • reset CMOS, no change.
Thanks in advance for any help
 
Reactions: Nevemsenki79

Lutfij

Titan
Moderator
Welcome to the forums, newcomer!

The F on that processor means that it does not have an iGPU on it, so how are you getting display to the monitor? What was the make and model of the PSU that you tried to rule out your current PSU isn't at fault? Can you inspect the CPU socket for any bent or broken pins?
 
Dec 4, 2020
2
1
10
0
Thanks for the response... I do have an RTX 2060. Let me add more data.

I was don't a case change for the PC. Everything was working ok on the old case, same PSU, same mother, micro, etc. But when changed to the new case, it stop working. When I connect the mother to the PSU I get the Strix panel lights on, and when I push the power button, all the fans start spinning, but I don't get any beep or Q-Led light on the mother.

I tested the PSU on anther build and it's working fine. I've also test the mother without CPU since, for now, i want to get any beep or Q-Led from the motherboard.

Thanks and regards
 

ASK THE COMMUNITY

TRENDING THREADS