Question Asus Z590 Motherboard - PC won't boot, green BOOT LED & white VGA LED stay lit ?


Dec 27, 2015
So I tried to turn on my system today morning, but it didn't boot. It didn't give any display and just stayed with a constant white light. Performed several hard-restarts from casing with no luck. As user manual states this to be a GPU issue, I removed GPU and checked with integrated graphics, then, in addition to constant white light, green light came up after 2-3 seconds, and system was stuck with these two lights.

Things I've tried since then:
Cleaning and reseating GPU
Checking with iGPU while GPU is still installed
Swapping and reseating memory sticks
Clearing CMOS (both jumper and battery removal methods)
Removing/disconnecting HDD & SSD
None of above worked. But everything was fine till yesterday.

Core i7-11700K
MSI GTX 970 OC (old age, needs upgrading)
Asus TUF Z590-PLUS WiFi
16GB Corsair Vengeance
850W Corsair RM PSU
Antec A400 air cooler (not enough, needs upgrading)

PC was built 10 months ago.
OS: Windows 10 Pro

Green/Yellow Green - BOOT
White - VGA
Orange - RAM
Red - CPU

I only have a DP cable, so I only checked using DP ports. Will need to buy and check using an HDMI cable too ?
This never happened with this system before. Could someone please help me with this?
Last edited by a moderator:


Dec 27, 2015
check if all connections are still fine
try updating /reflashing the bios by USB

After removing the GPU, did you perform a cmos reset? and plugged in the dp cable into the motherboard?
Yeah I checked twice, all connections are firmly in place.

As you said, this behavior may be caused by a bugged BIOS. I will try updating the BIOS to latest version.

Performed CMOS reset several times, before removing and also after the removal of GPU.
Clearing CMOS should reset the BIOS setting responsible for default/preferred graphics output.
Plugged DP cable into motherboard, just to check if it boots with iGPU. Then it started to stay stuck with these two lights.
breadboard the system with minimum setup outside the case (on a non conducting surface like wood or non foiled cardboard)
motherboard, PSU (connect ATX_12V_2 and ATX_12V_1, at least the 8pin ATX_12V_1 should be sufficient), monitor in motherboard while GPU is removed , one RAM in slot A2, CPU with cooler and fan connected to CPU_FAN header, keyboard

disconnect all other plugs/connections/fans/drives/USB/cards/M.2...

Is the CMOS battery installed correctly with plus visible?
Is the CLRTC jumper removed?


Dec 27, 2015
Just wanted to check it with an HDMI cable (used TV's cable, plugged to iGPU) before breadboarding. Whoa! it suddenly started booting normally.
Then I re-checked the system using same DP cable (with iGPU and GTX970 as well), booted without no problems. so the DP cable is fine??

Yes, the CMOS battery was installed with plus visible all the time. jumper seems okay.

My guess: BIOS was bugged for some reason. I want to know the reason, but how?
Anyway I will surely update BIOS to the latest version and let you know if something goes wrong.