Question asus z97-PRO unusual A2 code issue

Sep 17, 2020
1
0
10
0
So I'm having a very strange issue with this build. It worked perfectly for several years, then suddenly started failing to boot with Q Code A2 (IDE Detect) and no display. So I tried the typical solutions, check drive is still good, clear CMOS, flash update BIOS. And, once I flashed a bios update, the thing boots into windows, no issues! ...until it reboots. Once the machine powers off, it fails to POST with Q code A2 again, until I either clear CMOS or flash BIOS.

More weird things: on a successful boot into windows, nothing is displayed until windows startup. No "Press Del to enter Bios" or ASUS splash screen, anything like that. If I spam delete during a boot to try and enter bios after flashing BIOS (which would normally result in a successful boot to windows) I get an A2 code again. Also tried restarting into BIOS using windows startup options, same result.

I've been looking all over the internet, and while there are plenty of people with A2 boot issues, I've not seen a single post where they could boot into an OS once for some reason. My only guess is that the memory BIOS is on has somehow failed in a way that corrupts it shortly after being powered up... really hoping thats not the case because that would mean this board is toast. Anyone got any ideas?
 

ASK THE COMMUNITY

TRENDING THREADS