• Now's your chance win big! Join our community and get entered to win a RTX 2060 GPU, plus more! Join here.

    Pi Cast Episode 3 streams live on Tuesday, August 4th at 2:30 pm ET (7:30 PM BST). Watch live right here!

    Catch Scharon on the Tom's Hardware Show live on Thursday, August 6th at 2:00 pm ET (7:00 PM BST). Click here!

Question Asus zephyrus s gx502 won’t boot

Dec 30, 2019
5
0
10
0
Hello! This is my first post I’m trying to get some kind of help I have a asus zephyrus s gx502, it has a i7 9750 and a rtx 2070 in it the laptop just randomly shut off while gaming and wouldn’t boot. I don’t the technical term but I was instructed to drain power fully and it booted one time after doing so it shut down and will not boot again any ideas? Thank you in advance!
 
Dec 30, 2019
5
0
10
0
It won't turn on at all or does it get suck when loading Windows? You get lights, fans, BIOS screen, anything? If not, it's likely a dead motherboard, contact ASUS support.
it will not power up at all but I drained it by pulling the battery cable on the motherboard and it booted one time after seemed normal but I only ran it for 15 seconds before I shut it down and it won’t reboot anymore. This all just happened randomly while playing a game. For the record it has liquid metal in it installed by hidevolution.
 

hang-the-9

Titan
Moderator
it will not power up at all but I drained it by pulling the battery cable on the motherboard and it booted one time after seemed normal but I only ran it for 15 seconds before I shut it down and it won’t reboot anymore. This all just happened randomly while playing a game. For the record it has liquid metal in it installed by hidevolution.
Most likely issue is with the motherboard.
 

dfpamg

Prominent
Jul 16, 2018
1
0
510
0
it will not power up at all but I drained it by pulling the battery cable on the motherboard and it booted one time after seemed normal but I only ran it for 15 seconds before I shut it down and it won’t reboot anymore. This all just happened randomly while playing a game. For the record it has liquid metal in it installed by hidevolution.
Did you find a solution or did you just RMA or sent it to the store for a fix?
 

ASK THE COMMUNITY