_SunTzu_

Distinguished
Apr 5, 2006
99
0
18,630
hey everybody, i have an ati 4850 and its been working just fine till i got godfather 2 and everytime i try to play the game ... after a couple of minutes the screen turn black with "sync. out of range" message. what could it be?
power supply problem or overheating?

PS: i have to keep the fan speed in the ati overdrive at its 100% cz its been heating while under load. but when its at full speed theres no problem whatsoever with any application (even Crysis warhead) except for now.
 
What temps are you getting? GPUs run hot you know, it's OK if the card is around 80C.

You have some driver problem with the game is all. Try a different resolution or see if the game menu has an option for forcing V-sync.
 

_SunTzu_

Distinguished
Apr 5, 2006
99
0
18,630
well ive seen it sometimes getting to 90C
and ive tried different settings ... 1024x768 and 1280x1024, lowest and highest graphics still same prob. and ive downloaded the latest ati catalyst (v 9.5)
might there be any special settings that i have to put in the catalyst control center?
 
I find absolutely no info on your PSU anywhere. I would like to know more about it.

I can't say that it's your problem, but in general terms if I have never heard of it and a search turns up nothing, it needs to be replaced on general principle.

Any chance you could post a clear pic of the PSU label? I may be able to say more about it then.

You should probably list out all your specs as well.
 
Very shady PSU with no UL number. I find a possible manufacturer in China, but no indication if they are any good. There may be some relation to Enlight, which is no recommendation.


Can you get access to another PSU for testing? A quality 450W would be fine.

I have no way of knowing if the PSU is the problem for sure, and neither do you. All you can do is swap it out to test.

I can say I wouldn't allow that unit in any system I cared about.