ATI HD5770 Starcraft II slowdown

Status
Not open for further replies.

tripod_knight

Distinguished
Sep 11, 2010
20
0
18,510
Hello! I'm new to the community, but I've used the website in the past to find solutions to my problems. I think I'm a little out of my comfort area with this problem though. Thanks in advance for your help.

I just bought a new machine prebuilt ( http://www.tigerdirect.ca/applications/searchtools/item-details.asp?EdpNo=6077552&SRCCODE=CANBP236&cm_mmc=EML-_-Weblet-_-CANBP236-_-feedback )

Important Specs:
Asus P6t SE
Intel i7 930 2.8ghz
ATI HD5770
6GB triple channel DDR3 1333 ram

Now I think I should be able to run Starcraft II on ultra settings, and normally I don't have a problem doing so. However (for those that have played) whenever a mothership begins to cloak an amount of units I find myself having to bring the settings to low just to avoid a slowdown.

I just got the machine, is it possible some parts are defective? Do I just not have a good enough machine to run at max settings all the time?

I haven't verified all the components, and I'm thinking I may need to do this. Thanks anyone for your response, and I hope I don't have to send this computer back!
 
Solution


Either try some other games, or download the Free version of 3dMark06 or 3dMark Vantage. You can then compare your results with other people that use the same ATi 5770 graphics card and see if you're in the ball park.

Realistically though, I'm sure you're fine. Although I don't play SC2, I've heard of issues.

plznote

Distinguished
Jun 12, 2010
943
0
19,010
This is a common issue with StarCraft 2. This also happens with pylon power fields and Zerg Creep. I think a patch might fix this up. I might be wrong!? But you can check the Blizzard forums on stuff like this...
http://us.battle.net/sc2/en/forum/13438/
Hope this helps!
 


"Yeah but it says "Intel HD Accelerator" right on the sticker!!!!! I'm not even playing @ 1080P and it's slow!! It says HD!!"
 


Either try some other games, or download the Free version of 3dMark06 or 3dMark Vantage. You can then compare your results with other people that use the same ATi 5770 graphics card and see if you're in the ball park.

Realistically though, I'm sure you're fine. Although I don't play SC2, I've heard of issues.
 
Solution

cschuele

Distinguished
Nov 30, 2009
67
0
18,640
This has been closed for a while but I thought I would add that the new patch from 9/21/11 now only cloaks 25 units per second to avoid slowdowns from lagg. So if there was 115 units as the mothership appeared 1sec later 25 would be cloak, and after 5 seconds all 115 would be cloaked.
Cheers :wahoo:
 
Status
Not open for further replies.