ATi Mobility HD 5850 DX11 problem

lolpc

Honorable
Dec 30, 2012
22
0
10,510
Hello everyone, I seem to have a bit of a problem running DX11 on my laptop, which has a HD5850 GPU that is supposed to support DX11. However when I play Blacklight Retribution, I get loads of white pixels everywhere, like this guy is getting http://www.youtube.com/watch?v=yMoN1rX-1-8

However when I turn DX11 off, it works fine, but I wonder if this is something I can fix, I've updated the GPU driver, but to no avail. So I dunno what to do next. Any suggestions?
 

lolpc

Honorable
Dec 30, 2012
22
0
10,510
The 5850 is on the list of DX11 cards, the 5550 was the first ATi card.

@COLGeek

When playing Planetside 2 on medium/high it usually tops around 80-84C and when playing BF3 on medium/high settins I've seen it reach 86C. However in none of these games have I seen any graphical artifacts, they run great, which is why i'm surprised at how poor it runs Blacklight with DX11.
 

lolpc

Honorable
Dec 30, 2012
22
0
10,510
I'm a bit lost when it comes to ATi cards, do I only need to install CCC for the latest driver? If so, then I have it. But if I need to install something else, then I probably don't
 

lolpc

Honorable
Dec 30, 2012
22
0
10,510
I installed it today so I'd expect, yes.

I checked on my desktop (Has a Geforce GTX 680) and it has no issues running it with DX11. However I'm on the road most days so I primarily use my laptop for gaming, so this glitch is quite annoying, when the laptop should run it without incident.

The model of my laptop (If that matters) is a HP Envy 17 i7 1.60Ghz with turbo boost to 2.80Ghz, 8GB RAM, 2x 500GB and of course the GPU. And while it does get hot, I've never had any overheating issues.