ATI Win9x drivers are NFG.

Slug

Distinguished
Apr 2, 2004
115
0
18,680
Archived from groups: alt.comp.periphs.videocards.ati (More info?)

Yesterday I picked up a copy of amn older game called "Blade of
Darkness". I have two PC's and on one I have a mobile rack were I
switch between three hard drives. I decided to install "BoD" to WinME
and was using the Cat 4.3 drivers. Everytime I tried to run the
graphics configurator, which you must do before you can run the game,
it would crash with an unknown error in D3D.DLL. OK, so I installed it
to my other PC which is using a Geforce4 Ti4200 and there was no
problems at all there. I wanted to try it on my faster PC though
because the game is graphically demanding (looks very good for a 2001
game) so installed it back to the other PC but using XP as the OS and
the Cat 4.3 drivers, no problem again. It's just the ATI Win9x drivers
that have an isssue with this game. I even went back a version to the
Omega CAT 4.2 drivers and got the same problem. I've had a couple of
other issues in games with the ATI Win9x drivers but they run with no
problem on XP, and using the exact same driver version. I know ATI has
dropped support for Win9x now but at least they could make sure that
their drivers of the same version for both operating systems are of
the same quality. Creative doesn't support Win9x anymore and now ATI
has dropped support too, guess I better start looking for hardware
manufacturers that do in the future because I instend to keep on using
Win9x for some time to come, along with XP and Linux. Hardware
manufaturers should be supporting Win9x, Linux and XP, and I don't
mean half-assed drivers that are buggy either. The majority of the
people out there are still using Win9x based PC's so dropping suppport
just doesn't make sense unless you are towing the Micrsoft line.
Anyway, what gets me is that ATI's Win9x drivers of the same version
as XP have a bug that the XP ones don't so obviopusly they are not the
same version at all.
 
G

Guest

Guest
Archived from groups: alt.comp.periphs.videocards.ati (More info?)

im using win98se, aiw7500, cat 4.3. But every thing is working fine here.

Danny
--end

Slug wrote:
>
> Yesterday I picked up a copy of amn older game called "Blade of
> Darkness". I have two PC's and on one I have a mobile rack were I
> switch between three hard drives. I decided to install "BoD" to WinME
> and was using the Cat 4.3 drivers. Everytime I tried to run the
> graphics configurator, which you must do before you can run the game,
> it would crash with an unknown error in D3D.DLL. OK, so I installed it
> to my other PC which is using a Geforce4 Ti4200 and there was no
> problems at all there. I wanted to try it on my faster PC though
> because the game is graphically demanding (looks very good for a 2001
> game) so installed it back to the other PC but using XP as the OS and
> the Cat 4.3 drivers, no problem again. It's just the ATI Win9x drivers
> that have an isssue with this game. I even went back a version to the
> Omega CAT 4.2 drivers and got the same problem. I've had a couple of
> other issues in games with the ATI Win9x drivers but they run with no
> problem on XP, and using the exact same driver version. I know ATI has
> dropped support for Win9x now but at least they could make sure that
> their drivers of the same version for both operating systems are of
> the same quality. Creative doesn't support Win9x anymore and now ATI
> has dropped support too, guess I better start looking for hardware
> manufacturers that do in the future because I instend to keep on using
> Win9x for some time to come, along with XP and Linux. Hardware
> manufaturers should be supporting Win9x, Linux and XP, and I don't
> mean half-assed drivers that are buggy either. The majority of the
> people out there are still using Win9x based PC's so dropping suppport
> just doesn't make sense unless you are towing the Micrsoft line.
> Anyway, what gets me is that ATI's Win9x drivers of the same version
> as XP have a bug that the XP ones don't so obviopusly they are not the
> same version at all.
 

Slug

Distinguished
Apr 2, 2004
115
0
18,680
Archived from groups: alt.comp.periphs.videocards.ati (More info?)

On Mon, 03 May 2004 09:28:08 GMT, Danny Greaves <dandog@pacbell.net>
wrote:

>im using win98se, aiw7500, cat 4.3. But every thing is working fine here.
>
>Danny
>--end

Yes, most games work fine but there are one or two that have problems
on Win9x that don't have a problem on XP using the exact same driver
version.