Question atikmdag.sys page_fault_in_non_paged_area "BSOD"

Aug 5, 2020
14
0
10
0
I have dell 5567 laptop
core i7 7500u
intel hd620
r7 m 445
1T.B Storage HDD
8 gb ram

I have this problem keeps giving me BSODs with this error atikmdag.sys page_fault_in_non_paged_area "BSOD"
I have tried everything .. updating bios .. uninstall video card Driver with DDU in safe mode .. update it .. use factory version driver .. nothing seemed to work .. and laptop let me only to system if i uninstall my Graphic card driver .. it shows no more but it keeps me on intel hd 620 ..|

I have found out one more thing .. if i started my laptop without connecting it to the charger it let me in windows normaly .. then i wait a min or 2 and inistall amd driver ..connect charger and it works great .. but problem starts to happen again as soon i restart or shutdown my laptop .. please help me i have tried everything .. 2 different versions of windows 10 .. all kind of cmds i have found in youtube .. reddit and seems like nothing have worked ..

also there is something else i think i should mention when i tried to update bios hoping it would solve my problem .. at 1st i uninstalled my graphic card driver so it wont bsod while updating .. but surprisingly it did go into bsod while restarting for installing bios even tho my graphic card "amd r7 m445" driver was uninstalled .. but it went fine after all my bios got updated .. but problem still on and im really sad .. mad cant do anything to solve this please help.
 

Colif

Win 10 Master
Moderator
Do the drivers for GPU recognise card while you install them? Or do you get a BSOD while trying to install them? Or only after its installed you get BSOD?

which version of windows installed?
 
Aug 5, 2020
14
0
10
0
hello .. im very sorry for the late response , i installed latest windows 10 from microsoft..
I get bsods while installing amd driver , but if i installed while charger is not connected it installs normally.. but then i get bsods everytime i turn on my laptop while connected to charger .. i can only start it up on battery only .. then i start any game .. i connect charger fps becomes good and everything go back to normall till i close the game or try to start another game
 
Aug 5, 2020
14
0
10
0
umm i will try the updater on the dell site and let u know what happened .. do u need any logs ? or dump files ? . or bios settings "ttp/tpm" or anything .. cuz i believe they are the reason somehow .. " im a little nob"
 

Colif

Win 10 Master
Moderator
dump files might not tell me anything I can't already see. It is blaming atikmdag.sys , I know that is the Radeon drivers.
Can you follow option one on the following link - here - and then do this step below: Small memory dumps - Have Windows Create a Small Memory Dump (Minidump) on BSOD - that creates a file in c windows/minidump after the next BSOD

copy that file to documents
upload the copy from documents to a file sharing web site, and share the link in your thread so we can help fix the problem

it might identify something else that needs updating, you never know.
 
Aug 5, 2020
14
0
10
0
oki i used dell updater tool .. they didnt even show me that my amd r7 m445 needs to be installed or to get updated .. its like its not there in my laptop .. also device manager display it as "video controller" .. any way i try to install amd driver now and will upload the small memory dump file here
 

Colif

Win 10 Master
Moderator
i guess i can look at the installer log, not sure what it will show me.

were you on battery when you ran updater?

i wonder if its something to do with a power plan being different when you on battery compared to mains. your gpu would be getting more power when on power cable than on battery
 

PC Tailor

Splendid
Ambassador
Everytime @Colif states "I have sent dumps to a friend" I always think that I therefore CAN'T be his friend. Ah sad times. (I'm joking - GMs dump analyser is far better - I understand ;) ) Either way see if this helps for the time being:

I have run the dump file(s) and you can see the full report(s) in the link below.
If you are prompted to ""Run only if trusted"" simply click play/run and the html will be viewed. This warning is always present.

Report: https://jsfiddle.net/cxvemu6k/show

Summary of findings:
PAGE_FAULT_IN_NONPAGED_AREA
Bug check 0x50 can be caused by the installation of a faulty system service or faulty driver code. Antivirus software can also trigger this error, as can a corrupted NTFS volume.

It could also occur after the installation of faulty hardware or in the event of failure of installed hardware (usually related to defective RAM, be it main memory, L2 RAM cache, or video RAM).
 
Aug 5, 2020
14
0
10
0
i tried installing windows 10 several times .. with no connection so i download every driver from dell website and install in order as they mention nothing changed and i think its related to bios but i tried to update bios to latest and it still the same issue .. one thing i need to mention about bios is that .. my brother have the same laptop but his bios is older version i tried to find if there is difference in selected options between me and his laptop and i found out that he is running in legacy mode, and under security there is this thing called ptt he has it checked ✅ mine was unchecked .. anyway i tried to uncheck his ptt and his laptop ran into bsod just like me "when he starts windows" but it was a different error so i enabled it back on his laptop and everything went back to normal .. i couldnt apply it on my laptop cuz it needs to run my os in uefi mode so .. i did install my windows in uefi mode with ptt enabled but still same issue .. the only different between me and my brother is that he is useing legacy mode
its weird cuz he can enable it on legacy mode .. but my bios asks me to run in uefi to enable it but this thing didt work anyway so ..
. idk im so noob -.- but let me know if u need anything . i wish i could fly my laptop to u so you solve it for me in no time

sorry for all this just want to let u know every single detail -.-
 
Last edited:

Colif

Win 10 Master
Moderator
Everytime @Colif states "I have sent dumps to a friend" I always think that I therefore CAN'T be his friend. Ah sad times. (I'm joking - GMs dump analyser is far better - I understand ;) ) Either way see if this helps for the time being:
well, i can't assume you will look now can I. Now I have to tell GM to not look...

nothing old there I can see

where do you get the drivers from then?
atikmpag.sys 26/10/2017 ATI ATI video card driver
atikmdag.sys 27/10/2017 ATI ATI Video driver


ttp appears to be tpm. Trusted PLatform Module. I don't think it is needed.

Can you check in power options and tell me which plan your laptop is on when plugged in or not
right click start
choose power options
Click Additional Power settings to see what plan you are on now

PC did that for me :)
 
Reactions: PC Tailor
Aug 5, 2020
14
0
10
0
it works under power in 1 case .. i hold power button till laptop shutdown, remove charger , start my laptop , installed driver while im on battery and then connect charger .. i get bsods when I start laptop on charger while driver is installed "does not even let me to windows" .. i can only start my laptop on battery so i dont get bsods
 

Colif

Win 10 Master
Moderator
I thought it might be like that, need to save up for a new one or buy a desktop as then if gpu dies, you just replace it... not entire PC**


** long ago one of my PC's GPU died and I had to replace entire PC as it was at a stage when AGP graphics cards were being replaced by PCI E and I couldn't find a new AGP card... so that was the last time I replaced a PC cause GPU died. :)
 

ASK THE COMMUNITY