attaching USB 2.0 device crashes the computer

peter

Distinguished
Mar 29, 2004
3,226
0
20,780
0
Archived from groups: microsoft.public.windowsxp.hardware (More info?)

Hi, whenever I try to attach a USB 2.0 device to my
computer (a Shuttle XPC SS51 with an Award
BIOS), it freezes. If I disable the Enhanced USB
controller, however, the USB 2 devices work fine (but at
USB 1.1 speeds). This happened shortly after updating
the USB enhanced drivers to .1243 (Windows Update
822603). When I roll back the drivers though, the
problem persists. Just wondering if the registry got
corrupted in the process. Short of reinstalling Windows,
is there any way to get USB 2.0 to work again?
I have also switched on and off support for USB Legacy
devices, no effect.

--Peter
 
G

Guest

Guest
Archived from groups: microsoft.public.windowsxp.hardware (More info?)

Try deleting ALL the USB hubs, ports and devices with device
manager. Also disconnect any external devices such as flash
drives or hard drives. Then reboot and one set of drives
should be installed. The reinstall your devices one at a
time.


--
The people think the Constitution protects their rights;
But government sees it as an obstacle to be overcome.


"Peter" <chienp01.removethis@yahoo.com> wrote in message
news:86eb01c43245$c5c794a0$a101280a@phx.gbl...
| Hi, whenever I try to attach a USB 2.0 device to my
| computer (a Shuttle XPC SS51 with an Award
| BIOS), it freezes. If I disable the Enhanced USB
| controller, however, the USB 2 devices work fine (but at
| USB 1.1 speeds). This happened shortly after updating
| the USB enhanced drivers to .1243 (Windows Update
| 822603). When I roll back the drivers though, the
| problem persists. Just wondering if the registry got
| corrupted in the process. Short of reinstalling Windows,
| is there any way to get USB 2.0 to work again?
| I have also switched on and off support for USB Legacy
| devices, no effect.
|
| --Peter
|
 

Similar threads


ASK THE COMMUNITY