Question Audio drivers and my speakers aren't working

PC___Guy

Reputable
May 14, 2016
29
0
4,530
0
So basically, whenever I am using either the latest Realtek audio driver, the driver meant for the motherboard, or the generic audio driver from Windows, my speakers don't work. I've had this issue before, but with a lot of mangling around I finally, sometimesm get them to work. The speakers are a 5.1 logitech z506 system, and it's connected via 3 3.5mm jacks.

Two days ago the speakers weren't working, and, after properly setting up the system (I was missing one 3.5mm cord), the whole system worked. All 5 channels and the subwoofer worked in an actual 5.1 setup. I updated the computer for Windows 10, and then they didn't work, so I installed the driver meant for the motherboard and then it worked fully. The next day, after simply starting up the computer, I had no sound. Then, after doing the maneuver of uninstalling and reinstalling the drivers, I had sound in all but the two front left and right speakers.

I know the issue isn't the cords or anything physical (I think), but I don't know if the audio drivers are just acting up or if I should replace the system. I'm not too experienced in this area of computers, so my question is this: How would I go about fixing this?
 

PC___Guy

Reputable
May 14, 2016
29
0
4,530
0
While that would make sense, these drivers have had these issues previously without updates. Suggestions said to update to the latest drivers and even those ones didn't work.
 

ASK THE COMMUNITY

TRENDING THREADS