Question Avast boot scan has caused black screen with command prompt

06coopers

Reputable
Nov 23, 2015
30
0
4,530
0
I installed Avast's free anti virus today since I noticed high cpu usage at idle. It found two things on the scan which I cleared, I then had it run a boot time scan and restarted.

After putting in my pin for my main user all I get is a black screen with a command prompt window open. Ctrl+alt+del works and I can open task manager. I can switch to the other user on the computer and it goes to the desktop without a problem.

The only weird thing I noticed during the boot scan was it picked out a couple off my steam apps folders and said they were "decompression bombs"

Can anyone help me figure out what the issue is and how I can fix it?
 

onespeedbiker

Respectable
Apr 13, 2019
2,369
177
2,390
133
At the command prompt type explorer; that should give you your desk top. Either way run msconfig, or type at the command prompt and press enter; this will bring up the System Configuration window. Start on the General tab and make sure the Normal startup box is checked. Click on the boot tab and see if the "No GUI boot" box is checked; if so clear it. Then try a reboot. https://www.digitalcitizen.life/how-use-system-configuration-tool-all-its-awesomeness
 

06coopers

Reputable
Nov 23, 2015
30
0
4,530
0
At the command prompt type explorer; that should give you your desk top. Either way run msconfig, or type at the command prompt and press enter; this will bring up the System Configuration window. Start on the General tab and make sure the Normal startup box is checked. Click on the boot tab and see if the "No GUI boot" box is checked; if so clear it. Then try a reboot. https://www.digitalcitizen.life/how-use-system-configuration-tool-all-its-awesomeness

Thank you so much! Putting explorer into the command line got my desktop back.
However when I go into the configurator and try and change it from selective startup to normal, the apply box is greyed out. If I click around first then click on normal startup it will let me apply it and prompts me to restart to save the changes. After the restart it goes back to how it was. I have tried running msconfig as an administrator without any change
 

06coopers

Reputable
Nov 23, 2015
30
0
4,530
0
I don't understand your comment "If I click around first." You will have to clear the No GUI boot box first if it is checked. Also uninstall the Avast software.
Sorry, after I open msconfig, selective startup is checked off. If I hit normal startup, the apply box remains greyed out. If I click on anything else on the page before hitting normal, for example diagnostic startup, the apply box becomes available.

Avast was uninstalled and the no GUI box was never checked off
 

onespeedbiker

Respectable
Apr 13, 2019
2,369
177
2,390
133
First, don't worry about the Apply box, choose Normal startup and click Okay. If that does not work, make sure nothing is checked on the boot tab. Also click on the advanced Options on the Boot tab and make sure PCI and Debug boxes are not checked. If your PC still won't boot to the desktop, on the General tab, choose Selective start and make sure all three boxes are checked.

If you are comfortable with editing the registry (always save an export first). Use regedit to check the HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon key. Scroll down the right panel to "Shell" the entry should be explorer.exe. This is not usually the problem but it is worth checking.
 

onespeedbiker

Respectable
Apr 13, 2019
2,369
177
2,390
133
Another option is System Restore. Go to Control Panel-> Recovery-> Open System Restore. Hopefully System restore has been enabled. Click on Next Button and see if Avast created a restore point. If not, but there are restore points you have to decide if you want revert back to the restore date, which will remove files and apps that were downloaded/ installed since that date.
 

ASK THE COMMUNITY

TRENDING THREADS