Question B350 Gaming Pro Carbon BIOS Flash Failure

Dec 7, 2021
7
0
10
0
TLDR: I updated my b350’s BIOS to the most recent non-beta version available on MSI’s support site to be able to upgrade my Ryzen 7 1700 to a Ryzen 9 3900x. Nothing bricked but my PC will no longer post; after the very first flash update that I did, it would post, could use the PC for a few minutes but then it would blue screen, kept getting a Memory_management BSOD, ended up trying a system restore which did nothing; after the restore, my PC now only boots up to the ‘please recover your PC with windows installation media’ blue screen, and the only option my PC has given me up to this point is to fresh install Windows which will wipe my boot drive, and because I’m short sighted and stupid and still learning, I didn’t make back ups when I started using the drive earlier this year. Tried flashing back to many older BIOS versions, nothing changed, so in the end I flashed forward again to the newest non-beta BIOS version, figuring if I ended up getting the pc to post, I might as well have it updated so I can possibly use the 3900x I purchased.

Hi all, this is my first Tomshardware post ever so bear with me. I’m not super savvy with PC building/components but I’ve been making an effort to learn more lately. Above is my tldr of my BIOS issue (which I realize is still long-winded, sorry) but below I will paste in my even longer winded summary that I wrote to my work’s IT guy (who didn’t help me at all lol)

“This all started because I wanted to upgrade my Ryzen 7 1700 to a Ryzen 9 3900x (which is still on hold because the bios update didn’t fully work). I have an old b350 motherboard and my goal was to flash the bios to the newest version so that my board would be compatible with 3000 series cpus. I did a lot of research beforehand to make sure it would work and that I wouldn’t have any compatibility issues, and on paper the whole process was very straight forward, and I had read of countless other people having success doing exactly what I wanted to do, so I felt pretty confident about the whole endeavor. I did the flash update with no problems (or so I thought), but it triggered something else and I don’t know what it is. At first the PC would post, but after a few minutes of doing anything I would bluescreen with a memory_management error code. IIRC I tried to system restore to a point that was automatically made 3 days ago, no luck. I believe after I did the system restore (which is no longer an option) the computer would no longer post and I’d get blue screened, specifically the “you need to use Windows installation media to recover your PC” upon boot up. Before that permanent recovery blue screen, the first error code I received was memory_management, I’ve also seen critical error failure, and I think there was one more but I can’t remember the error code; since nothing was working I tried flashing back to an older bios version thinking that would undo the mess I made, I actually tried that several times with different older versions, but the outcome was always the same with nothing getting better (or worse, thankfully), so I ended up flashing back to the most recent bios update. At the moment the only thing that my PC seems to wanna let me do is to fresh install Windows through an installation media usb, the annoying part is that it won’t let me do the “repair/upgrade current windows” feature because even though my computer has windows installed of course, my system won’t post so it denies me any option except fresh installing, and that’d be fine, but I don’t have backups because my two SSDs are less than a year old and I was too shortsighted to make backups during that installation earlier this year. Big oof.

If the fresh windows install was 100% guaranteed to fix my problems I would probably just bite the bullet and do it, but because the outcome is unknown to me currently the risk of fresh installing just isn’t worth it, at least until I do some more digging to see if I can’t find some other solution to get me up and running again.
I’ve tried taking my ram out and putting it back in, resetting the cmos battery, neither of those did anything.
I read online that it’s possible that MSI, my mobo manufacturer, sucks at drivers/software updates etc and that it’s possible that when I flashed to the most recent bios, I actually removed my mobo’s ability to support my older & currently installed cpu, which also removed my ability to flash back to older BIOS versions. I have the 3900x in hand so if I find out that that’s actually the issue, I can replace my 1700 and be golden, though somehow I truly don’t think it’ll be that easy. The good news is I don’t believe I bricked anything throughout all of this surprisingly enough, but I’d love to not have to fresh install windows.”

I pulled an all nighter troubleshooting so that I could be ready for work in the morning and in the end had to call out (work from home) because I was defeated by this problem. I scoured Reddit/tomshardware/google from late PM to early AM and haven’t found a solution, but I refuse to give up. Any and all insight is appreciated, and apologies for any redundancies in my post that I repeated on accident, just wanted to make an effort to be as clear as possible.

B350 Gaming Pro Carbon, Windows 10

Ryzen 7 1700

650(?)W PSU (I need to double check it tbh)

2x 8gb Corsair Vengeance DDR4 ram

1TB Samsung Evo SSD (boot drive) and a 500gb one

GPU: 3060 (I’ve been using a 1070 up until 2-3 weeks ago, kind of irrelevant but figured I’d mention it)
 
Wow...TLDR...

Sounds like a cold brick. Reset CMOS by pulling battery and leave it out overnight. Also short the pins, do it both ways.

B350 boards are junk, there's no other way to put it. This is just the sort of thing most people experienced with them back at the launch of Zen1. Even if you ever get it to work ou're much better off swallowing a pill and getting a decent B450...or better yet B550 board...for that 12 core/24 thread CPU.
 
Reactions: TheBeatboxer
Dec 7, 2021
7
0
10
0
Just what I didn’t wanna hear haha. Thank you for your reply. Ive let it sit out for 5-10 min but haven’t left the CMOS battery out overnight yet so I’ll try that and I’ll google how to short the pins, never done that one.
I hear you about the board upgrade, I wanted to stretch the life of this build as far as possible but regrettably the end is closer then I anticipated.

If anyone has anymore input I’m still all ears!
 

ASK THE COMMUNITY

TRENDING THREADS