Question B360 BTC Pro 2.0 will not POST ?

Jun 2, 2022
Hey, a bit new to computer building but I built my first one successfully a few months back. This is my second build. This time I was looking to build a GPU mining rig which is probably apparent by the motherboard type....

I have tried to get the motherboard to boot into BIOS and it seems it goes into a boot loop.

The Mobo turns on then turns off (1) then turns on then turns off (2) then turns on (3) and WILL STAY ON and all fans are working. Also,the riser lights up and the 3060 Ti fans spin... However, there is no post screen (nothing on the screen at all).

I have tried plugging in the HDMI mobo to HDMIMonitor
I have tried plugging in the HDMI 3060 Ti to HDMI Monitor
I have tried plugging in the DisplayPort 3060 Ti to DisplayPort Monitor
I have tried unplugging the GPU and all power cables and just booting without it
Taking RAM out, putting RAM back in
Changing RAM from Slot 1 to Slot 2
Unplugging all cables and Plugging them back in
Reset CMOS by unplugging Power then putting a screwdriver on the JCMOS1 for 10 Seconds then plugging the power back in

The only thing I haven't tried is taking the CPU out and putting it back in? I believe the Celeron G3900 has onboard integrated graphics though? So would this mean there is an issue with the CPU?
Could the CMOS battery be an issue?

Any help regarding additional troubleshooting steps would be very much appreciated. Thank you in advance for your time.

Here is the basic information (all items are new):

MoBo – TB360-BTC Pro
RAM – Vengeance LPX DDR4
CPU – Celeron G3900
SSD – Kingston A400 120 GB
PSU – EVGA 1600W P+ Supernova Platinum

Connections are as follows:
Mobo ATXPWR1 24 pin to 24 Pin on PSU (MB)
Mobo ATXPWR3 8 Pin to PSU (4+4) (CPU1)
SSD Sata Power to PSU (SATA1)
SSD Sata Data to Mobo (SATA1 Header)
Graphics Card EVGA 3060 Ti 8 Pin to Splitter >>> Splitter to 6pin Riser >>>Splitter to PSU (VGA1)
Riser to PEX16_1
RAM is in Slot1
CPU Fan wire to CPU Fan Header (This fan works when trying to boot)
Other Fans go to SYSFAN1 and SYSFAN2 (These work properly when trying to boot)
Jun 2, 2022
Well, as it turns out the G3900 processor is not compatible...

I was looking at the BTC250 and BTC360 and I must have mixed up the pages. It is compatible for the BTC250.

So I'm guessing once I get a new processor the system should now post? Is there anything I should be worried about by accidentally using the wrong processor initially?

Thank you so much for taking the time to answer. Boy do I feel silly 😔