Question B450 Gaming Pro Carbon POST Issues

Sep 16, 2019
2
0
10
0
Hello, I wonder if someone can help me as my set up is not POSTing at all. No display is available and im not sure how to go about it (it’s my first time building a PC). My set up is:

MOBO – B450 Gaming Procarbon AC
PCU – Ryzen 2700X
RAM – Ballistix 2X16GB 3000MhZ
VGA – Gigabity GEFORCE GTX 1660
SSD – Samsung EVO 250GB
HDD – WD Blue 1TB
PSU – Seasonic Focus Gold 550FM

I have my monitor (Sceptre E24) connected to the MOBO through the HDMI port, as well as a keyboard & mouse (im working with MOBO outside the case to troubleshoot)

Some background info- earlier today, all LEDs (CPU, RAM, and VGA) were turning ON then OFF, except for the BOOT LED which would stay ON forever.

So I followed the process in this forum - https://forum-en.msi.com/index.php?topic=310678.0, using BIOS version 7B85v19 from MSI website (During the refresh, im disconnecting the RAM and VGA, only CPU is connected). After refreshing the BIOS, the BOOT LED turned OFF, and the MOBO seemed to be working properly with the CPU and VGA fans running well, though no POST (no display available).

While I wrote this post, I turned off the MOBO and later I turned it on, to see if something changed and the BOOT light was once again ON and not turning OFF. So I refreshed the BIOS once again 7B85v19, restarted the MOBO, and the LEDs cycled and all of them turned OFF, but still not POSTing/no image. My mouse and keyboard are powered (LED are lit up)

I’ve been looking everywhere online, and it seems to be a common issue with the B450 Gaming Pro Carbon AC, but seems others have been able to solve this issue through BIOS refresh, though in my case im not. Any advice if highly appreciated.
 
Sep 16, 2019
2
0
10
0
I had the MOBO OFF all night, i just turned it back ON and now the BOOT LED is back ON. I restarted the MOBO 3 times and same thing.

I also tried unplugging the monitor and nothing.
 

TimH77

Commendable
Jul 21, 2017
115
4
1,595
1
Just a quick thought (and maybe not a correct one because I was wondering if my onboard video worked but didn't try it). I'm working on the same mobo and CPU build. You have the monitor connected to the onboard HDMI? The 2700x has to be used with a discrete graphics card, so try connecting your monitor to it.
 

ASK THE COMMUNITY

TRENDING THREADS