• Find an incredible deal for Black Friday or Cyber Monday? Share those epic bargains with the community by posting them in this forum thread!

Question B450 Steel legend won’t boot.

tristan_vidal888

Prominent
Jul 13, 2018
9
0
510
0
Hey guys,
I have a ASrock b450 steel legend mobo that was working fine at first, was running it for a week with the psu outside of the case because I couldn’t figure out how it fit until I finally figured it out. Anyways I brang it to my friends house and he’s good with PCs and he built mine for me, he put it back together and it wouldn’t start at all only the rgbs on the mobo would work. Now we sat there for 3 hours trying to figure out why it wouldn’t start we re plugged everything back in triple checked and it all seems correct.

GPU- gtx 1060
CPU- ryzen amd 3600
PSU EVGA WHITE 500w
mobo- ASROCK B450 steel legend
RAM- VENAGNCR Corsair 16gb

Any ideas would help I’m at a loss I just want to game again.
 

PC Tailor

Distinguished
Herald

tristan_vidal888

Prominent
Jul 13, 2018
9
0
510
0
As a first port of call, cover each and every step in this guide first my friend - thoroughly - and even if you have already done some of the steps: https://forums.tomshardware.com/threads/perform-these-steps-before-posting-about-post-boot-no-video-problems.1285536/

When you say it doesn't start, what exactly happens when you press the power button?
You say that it was running normally in Windows before the reassembly?
Yes it was running fine yesterday, my friend came over and we completely took it apart again put it back together just how the manual says and it still refuses to start. I jumped it and it wouldn’t even start still but the psu powered on. I couldn’t only get power to the motherboard lights. We suspected it may be the case button but we hooked it up my old case and it still would not start. I checked for broken pins I did not find any.
 

tristan_vidal888

Prominent
Jul 13, 2018
9
0
510
0
Yes it was running fine yesterday, my friend came over and we completely took it apart again put it back together just how the manual says and it still refuses to start. I jumped it and it wouldn’t even start still but the psu powered on. I couldn’t only get power to the motherboard lights. We suspected it may be the case button but we hooked it up my old case and it still would not start. I checked for broken pins I did not find any.
Yes it was running fine yesterday, my friend came over and we completely took it apart again put it back together just how the manual says and it still refuses to start. I jumped it and it wouldn’t even start still but the psu powered on. I couldn’t only get power to the motherboard lights. We suspected it may be the case button but we hooked it up my old case and it still would not start. I checked for broken pins I did not find any.
The only thing I don’t have is the motherboard screwed in but I didn’t before I also don’t have risers under it(ATLEAST all of them) but it was running perfectly fine for a week straight no issues before I decided to take it apart and full put the psu in the case. I’m not sure what to do anymore if I should just give up on it send it all back cause maybe it shorted out?
 

ASK THE COMMUNITY

TRENDING THREADS