Question B450M DS3H mobo works with r5 1600 but not ryzen 3 3200g

Dec 6, 2019
13
0
10
0
so my sister bought a gigabyte b450m ds3h, a ryzen 3 3200g and 1 stick of 16gb ddr4 2400mhz
i currently have a am4 setup myself so i was able to test everything on my rig as well, the r3 3200g works and so does the ram

the first ds3h that arrived was able to post with the 3200g even without bios updates but was defective somewhere as everytime windows started to load the board restarted (perhaps vrm issue?) after some more tries the board went completely dead leds on and fan spin but no post at all even with my r5 1600 and gtx 970, so she send it back to get a replacement

now the second ds3h that arrived works with my r5 1600 and gtx 970, though i didn't make stability tests on windows i just used it to update the bios,
this one however doesn't work with the r3 3200g at all, i tried the f40 (yes i updated to f32 first) bios and the latest f50 released just a few days ago.

i tested it on a breadboard with only cpu, ram and a speaker installed, and i cleared the bios every time i switched cpu
when i put in the r5 1600 it power cycles 2 times, beeps and posts normal
with the r3 3200g whoever mobo turns on but it doesn't power cycle or beeps at all


TLDR: i know all components are good but the B450M ds3h simply won't recognize the ryzen 3 3200g even though it should

i'm farly confident to assume the problem is in the bios or mobo itself but why did the first one recognized the 3200g but not the second?
i'm safe to assume this board is also defective if it doesn't support the ryzen 3 3200g even though it should?



CPU: r3 3200g
Motherboard: B450M DS3H
Ram: 1x16gb 2400mhz
SSD/HDD: none
GPU: gtx 970
PSU: gamemax gm500
Chassis: none
OS: none
 
Last edited:

Lutfij

Titan
Moderator
You should list your specs like so:
CPU:
Motherboard:
Ram:
SSD/HDD:
GPU:
PSU:
Chassis:
OS:

for your sister's system. As for your board, how did you clear the CMOS? By removing the battery from the board while the rig is powered down and with the wall socket switched off? I'd leave it out for 30 minutes at least before retrying to get the board up.

Which ram slot are you working with on the board?

Did you jump straight to F50 from F40, skipping through F41 and F42h?
 
Dec 6, 2019
13
0
10
0
updated the post
the board came with f42h though i don't know if the seller updated it in the correct order so i updated to f50 tested the cpu din't work, them i rolled back to f32 then f40 which should support the 3200g

i tried all the ram slots but i know ram is not the problem because it posts with my r5 1600
and yes i clear the bios by removing the battery and yes i tried leaving the battery out for extended periods of time
 
Dec 6, 2019
13
0
10
0
solved it
the 16gb cheap chinese ram that she bought doesn't work with the 3200g for some reason even though it works with my r5 1600 on the same board

i tested with one 8gb ram from my rig and it posted fine

i discarded the ram as an issue initially because i tested on my system and it worked fine
so if any of you have problems with newer gen ryzen not posting try out different ram
 

ASK THE COMMUNITY

TRENDING THREADS