Question B550 and AMD 5600g

Dec 6, 2021
11
1
15
0
My games keep crashing under triple A titles on steam. they worked fine until I got a new Ryzen 5600g and an ASRock b550-HDV AM4 AMD Micro ATX. I have taken the computer back to factory reset, fresh installed windows, nvidia drivers and all games. But for some reason they just crash when they start up. no tech support tips have helped including doing clean restarts and clearing steams cache to name a few. Any help would be appreciated. BTW my motherboard is on BIOS 1.9 which is that latest.
 
Dec 6, 2021
11
1
15
0
Curious...do you have an Nvidia dGPU? else why install Nvidia drivers. I wonder if you shouldn't also install the AMD drivers for 5600G for it's iGPU.

And finally: did you ever reset CMOS after installing the processor and updating BIOS?
Yes my GPU is an ASUS geforce KO 3060 ti. I was curious when I saw about 10 drivers under my CPU because it does come with dedicated graphics. And no I did not reset the CMOS I am not sure what that means.
 
Yes my GPU is an ASUS geforce KO 3060 ti. I was curious when I saw about 10 drivers under my CPU because it does come with dedicated graphics. And no I did not reset the CMOS I am not sure what that means.
Resetting CMOS clears all the BIOS settings and returns them to default ones, even those you can't see or change. It should always be done any time a major hardware change is made...like CPU or memory in particular but also after BIOS updates. It should also be done when a system is first built as you never know what was in it before you got it.

You have to open up the system and short two pins on the motherboard. Be sure to turn off and remove the power cord first. Look in the manual where the two pins are located.
 
Last edited:
That's showing a problem with the gpu and the ram.

When you got this new mobo how did you do the fresh install of windows?

Ram.....look in the bios for xmp or docp and enable it.
Gpu.....perhaps clean out the driver with ddu and reload the driver.
 
Reactions: kurdtnz
Dec 6, 2021
11
1
15
0
I took it to geek squad so they would wipe all 3 of my drives clean (I had windows cloned across all 3 and thought that was the issue). Then they installed windows onto my M.2 with my key.
 

ASK THE COMMUNITY