[SOLVED] B550 Aorus Elite V2 Motherboard Not Responding in a New Build

works_arc

Prominent
Apr 7, 2021
70
3
535
0
Hello - I just completed a new build and I am unable to get to the BIOS of the B550 Aorus Elite V2 Motherboard by pressing the Delete key, as instructed by the American Megatrends prompt. Here is my setup

CPU - Ryzen 5950x
GPU - RTX 3060ti
MoBo - B550 Aorus Elite V2
RAM - GSkill Trident Z Neo 32 GB
PSU - EVGA Super Nova 950 Gold
SSD - Evo Pro 1 TB
Cooler - Be Quiet Dark Rock Pro 4
 

Darkbreeze

Retired Mod
Try a different keyboard.

Try plugging the keyboard into a USB 2.0 port on the back of the board OR into a 3.2 (Try both blue and red ports) if you are already plugged into a 2.0 (Black).

Is your keyboard wired or wireless?
 

works_arc

Prominent
Apr 7, 2021
70
3
535
0
Try a different keyboard.

Try plugging the keyboard into a USB 2.0 port on the back of the board OR into a 3.2 (Try both blue and red ports) if you are already plugged into a 2.0 (Black).

Is your keyboard wired or wireless?

I have tried wired and wireless keyboards, and I have tried every USB slot.
 

works_arc

Prominent
Apr 7, 2021
70
3
535
0
Might need a bios update first. Thankfully that board has Gigabyte's version of flashback, so you can flash the bios without needing an older CPU.
Thanks for that - I tried to install update F15d but that made no difference. Maybe I am doing something wrong? I rename the Efiflash file to gigabyte.bin, insert the flash drive into the USB slot that is below the Qflash switch and I push the Q flash button.
 

ASK THE COMMUNITY

TRENDING THREADS