Question B550 tomahawk with ryzen 5 5600x - BIOS flash via USB not working

Nov 9, 2020
3
0
10
0
I have just changed my motherboard to a MSI b550 tomahawk with a new cpu ryzen 5 5600x, its constantly stuck with the EZ debug cpu led on when starting with no display detected at all. I've tried 3 different usbs with the bios update file from MSI's website and everytime it will start to flash a few times when pressing the bios flash button on the back, the pc will start itself and the fans will start spinning but the bios led will just continue to flash and not stop at all. I have waited for an hour previously to see if it would work but it just keeps flashing. Is there any solutions anyone may have? Would be greatly appreciated.
 
I have just changed my motherboard to a MSI b550 tomahawk with a new cpu ryzen 5 5600x, its constantly stuck with the EZ debug cpu led on when starting with no display detected at all. I've tried 3 different usbs with the bios update file from MSI's website and everytime it will start to flash a few times when pressing the bios flash button on the back, the pc will start itself and the fans will start spinning but the bios led will just continue to flash and not stop at all. I have waited for an hour previously to see if it would work but it just keeps flashing. Is there any solutions anyone may have? Would be greatly appreciated.
Are you trying to bios flash with the CPU installed into the motherboard?

I believe the USB bios function is intended to work without the cpu installed.....

I found a vid about how to do this (as there aren't any instructions I could find quickly on the MSI website):
View: https://www.youtube.com/watch?v=rTBs0-gTJRI


Note that there are some specific requirements on the formatting of the flash drive and such, hopefully that helps.
 
Nov 9, 2020
3
0
10
0
I have tried and followed the method in the video and it still just flashes constantly, it never goes to a solid light or goes off... I'm so confused as to why it looks like it's working and just never stops blinking.
 
I have tried and followed the method in the video and it still just flashes constantly, it never goes to a solid light or goes off... I'm so confused as to why it looks like it's working and just never stops blinking.
Have you tried a different bios version (if there are any others available that support the 5000 series cpu?)

Edit, looking on the MSI site, there appears to be 2 versions of Bios that should support the 5600X... version 7391vA3 and 7381vA4.... whilst the latter is the optimal version for the cpu, the older one includes AGESA 1.0.8.1 which does include Ryzen 5000 cpu support. Might be worth trying that to see if you can get the system started. Once it's running you can then update to the newer version from within the bios itself.
 
Last edited:
Nov 9, 2020
3
0
10
0
I have tried various Updates from MSI'S page ranging from latest to oldest, it still has the same issue. I have tried 3 different usb drives as I've seen that as a viable solution but it has not been for me.
 

Giras

Honorable
Feb 24, 2015
137
3
10,715
5
hi i have almost same issue with b550 but uu can try diffirent usb stick ihad same problem and chnaged to other usb stick format it to fat32 and rename bios file to msi.rom copy and if led blink only few sec some is wrong repeat i had same problem for like 10 times chnaged 2 usb stick and 3rd worked asap , process is like 5 min max and when stop blinking is over is auto restarts shut down pc , install cpu and done
Hope this helps someone
 

ASK THE COMMUNITY

TRENDING THREADS