Question B560M Aorus Pro & single SP120 RGB Pro Fan no lighting up

Sep 28, 2021
38
5
35
0
Hi All,

Sorry for dumb question but I need some clarification regarding SP120 RGB Pro Corsair case fan.

I am building pc at the moment using Corsair 4000D case. I have replaced standard fan from the back of the case with RGB type SP120.
Connected it up to motherboard (B560M Aorus Pro). New fan spins ok but there is no light.

What am I doing wrong. RGB connector from the fan is plugged to Sys_Fan port. Perhaps I am looking at the wrong port ?

I have seen these RGB controller hubs , should it be used with just a single fan ? Or should the connection from motherboard be enough for just this one fan.

I am not sure at this moment if I will be adding any more RGB fans to this case.

Please let me know where I am going wrong.
 
Last edited:

Lutfij

Titan
Moderator
RGB connector from the fan is plugged to Sys_Fan port.
That's what you're doing wrong. The SYS_FAN header caters to the 3pin or 4pin fan header, not an RGB or ARGB header from a device. Yes the Lighting node hub is what you need to pair that fan's RGB connector. FYI, that RGB connector is proprietary;
 
Sep 28, 2021
38
5
35
0
Just a question to ask. I can see that there are two types of hubs available with big difference in prices between them.

1. £10 Corsair RGB Hub with SATA connection.

2. £55 Corsair Commander Pro Digital Fan and Lighting Controller

So far I only have one fan, I wasn’t planning on buying more.
What’s the difference between these two, can option 1 works too with my setup or should it be only option 2.
 

ASK THE COMMUNITY

TRENDING THREADS