[SOLVED] B650 PG Lightning M.2 SATA Not Showing Up

Ceilingcat

Distinguished
Apr 1, 2013
23
0
18,510
0
I just built my new PC, which everything went smoothly for the most part. However I have 2 different M.2 SSDs, one of which, just isn't showing up in the BIOS or Disk Manager. My WD Black SN 770 shows up fine and has my Windows Installation on it. However the WD Blue that I also purchased does not show up in the BIOS or in the Windows Disk Manager. I also downloaded easeUS and it does not show up in there either. Any help if possible is greatly appreciated.

Specs:

Motherboard: ASRock B650 PG Lightning

GPU: AMD 6700XT

CPU: AMD Ryzen 5 7600X

RAM: 32GB 5600Mhz Corsair Something or other

OS: Windows 11

SSD 1: WD Black SN770 1TB (Shows up and works fine, with the OS installed)

SSD 2: WD Blue 3D NAND 2TB Internal SSD - SATA III 6Gb/s M.2 2280 Solid State Drive (This one does not show up in 2 of the 3 M.2 slots available. The only one I haven't tried yet is the one my WD Black is slotted into, will update if and when that doesn't work).
 

Ceilingcat

Distinguished
Apr 1, 2013
23
0
18,510
0
Thanks! I actually, just noticed this finally when looking into it more this morning. It's really weird to me becuase I'm pretty sure the Motherboard Manual specifically shows them installing a B & M Key SSD even though the motherboard doesn't support that. But I appreciate the reassurance that that is the case. Guess I'll be returning that one and getting a new one.
 

ASK THE COMMUNITY

TRENDING THREADS