Question Bad audio quality with PRIME ASUS B450

DonMakav3li

Commendable
Aug 5, 2019
15
1
1,515
0
Hello!
I recently bought a new ASUS B450 mobo and everything has been fine except I think I have an audio quality problem, whenever I'm listening to music on very high notes I can notice the audio kind of like tearing? The best way I can explain it is when you use those very cheap earbuds with low quality, it sounds like that, but if I use the same headphone on my phone listening to the same song it sounds completely fine so it can't be because of my headphones or the quality of the song, is this because of the bad quality of onboard soundcard? Keep in mind my headphones are connected using USB.
 

jojesa

Illustrious
Hello!
I recently bought a new ASUS B450 mobo and everything has been fine except I think I have an audio quality problem, whenever I'm listening to music on very high notes I can notice the audio kind of like tearing? The best way I can explain it is when you use those very cheap earbuds with low quality, it sounds like that, but if I use the same headphone on my phone listening to the same song it sounds completely fine so it can't be because of my headphones or the quality of the song, is this because of the bad quality of onboard soundcard? Keep in mind my headphones are connected using USB.
A USB headphones does not uses the Realtek sound chip on the ASUS B450 mobo, it uses Windows audio codecs.
Have you try the USB ports on the back?
 

DonMakav3li

Commendable
Aug 5, 2019
15
1
1,515
0
A USB headphones does not uses the Realtek sound chip on the ASUS B450 mobo, it uses Windows audio codecs.
Have you try the USB ports on the back?
It is already connected to the back, I also have the same problem using 3.5mm, is it possible that it's a software problem?
 

jojesa

Illustrious
Did you installed the Realtek audio drivers from the motherboard manufacturer website?
Have you try the headphones in another device to see if the issue is the headphones.
Did you installed standoffs on the case before installing the motherboard?
Disconnect the PC case front audio and USB cables from the motherboard and see if that helps with the sound quality.
 

DonMakav3li

Commendable
Aug 5, 2019
15
1
1,515
0
Did you installed the Realtek audio drivers from the motherboard manufacturer website?
Have you try the headphones in another device to see if the issue is the headphones.
Did you installed standoffs on the case before installing the motherboard?
Disconnect the PC case front audio and USB cables from the motherboard and see if that helps with the sound quality.
It seems like it was a format/software problem, I played with the audio settings and renderer and it sounds better now. Thank you anyway!
 

ASK THE COMMUNITY