Question Bad Bios Checksum Help??


Nov 29, 2017
I have had problems with my Sabertooth x58 for some time now. I must have shut it down while bluescreened or something. I didnt have a video output and I just held the power button down. Ever since then I have been having DRAM problems. I took out my ram, I cleared the bios a million times. I have six channels so I painstakingly tested each individual one with 6 different ram sticks. I used the MemOk! button to no avail. But something new happened. I got a "bad bios checksum" error. I thought I was getting somewhere but now I am stuck.

I tried burning the bios file to a CD. I tried a 4gb flash drive then a 2gb flash drive. Both in FAT and FAT32 using rufus. I renamed the bios file to what the checksum was looking for but every time it says reading SABTOX58.ROM then it says it is not found. I don't know what else to do. I put the usb in the USB2.0 slot under the PS/2 port. I don't have the original install cd so I don't know if I burned the file right on my cheapo cd. I also bought another bios chip since the bios chip is swappable on this motherboard and still no dice. I can't find any solutions online and I feel like I'm the only one with this problem. I feel like I'm so close but I am stuck at this wall. Please any tips?

Things I did (in case you suggest this, cause I did read alot of stuff).
New CMOS battery
New Power Supply
Different Ram
Reseat CPU
Unplug every peripheral
Bought a new Bios Chip
Let the motherboard sit empty for days
used the jumpers on the motherboard