Question Bad gpu?

May 10, 2019
5
1
15
0
System:
A10 6800k
Gibabyte GA-F2A85XM-HD3
8GB ddr3
500w bronze rated
Rx570

I got a new pretty old system given to me off of a family member, and it didn't have a dedicated you, so i bought one. I got a rx 570, somthing good enough for 1080p gaming, but not too powerful for my cpu to strain, but it has various issues. First time installing it, there was no vido output from the gpu. Once it did start to work it, and i got the drivers updated, I op end a game up then it started to screen tear and mess up, then following with no game video output. I can still see my screen, but just not the game its self, i tried on another game and it says it has a fatale error, and shut down. Is it a bad you, memory, power, or what? I'm really new to pc's and have very little idea...
 
I'm guessing that this may also solve my current issue?
Even though your current issue might not be fully related to this ACE PSU, it's not advisable to use this power supply brand/unit for any gaming PC. To narrow down your current issue, it would be nice if you can get some other power supply unit though.

That PSU might be the culprit, though I can't be 100% certain. But like @Dark Lord of Tech mentioned above, the quality of this PSU is indeed horrible. Avoid using this unit.
 
Last edited:
May 10, 2019
5
1
15
0
Even though your current issue might not be fully related to this ACE PSU, it's not advisable to use this power supply brand/unit for any gaming PC. To narrow down your current issue, it would be nice if you can get some other power supply unit though.

That PSU might be the culprit, though I can't be 100% certain. But like @Dark Lord of Tech mentioned above, the quality of this PSU is indeed horrible. Avoid using this unit.
Okay, thanks, I'll get that sorted :)
 
Reactions: Metal Messiah.

ASK THE COMMUNITY

TRENDING THREADS