Question BAD PERFORMANCE AFTER NEW GPU INSTALLED

Jan 18, 2021
1
0
10
0
I've been trying to figure out what has been causing my pc to run terribly since I upgraded from a GTX 1060 3GB to an RTX 2070, I've used DDU to uninstall and then reinstall my drivers, I'm unsure if its a CPU bottleneck, I just need help finding out what my problem is. I've ran benchmark after benchmark and everything seemed to run fine until I go in game. Can anyone help me find an issue?

Here's my specs:
Ventus RTX 2070
Intel i7 7700 (non k)
4x4gb G Skill Ripjaws Ram
EVGA 600B PSU
Running on an 23.8 ASUS TUF 1080p 144hz
 

ern88

Distinguished
Jun 8, 2009
854
12
19,015
8
I upgrade from a GTX 1080 to an RTX 3080. I used DDU to perform full clean of my driver's in safe mode. And installed the 3080. I had problems as well. So I just did a clean install of Windows 10 and started from scratch. No more problems.Also, make sure you the RTX 2070 is connected correctly to the PSU. I think that card requires and 8 pin and a 6 pin power cables compared to the 1060 with just a 6 pin connector.
 

Wolfshadw

Titan
Moderator
I've used DDU to uninstall and then reinstall my drivers
This is what likely caused the problem.

According the the Geforce Driver Download Page, if you've updated your GTX 1060 drivers since the RTX 2070 came out, you did not need to update them when you did install the new card. The drivers you already had installed support both the RTX 2070 and the GTX 1060.

Just try to download and install the latest driver package again (without removing your current drivers).

-Wolf sends
 

ASK THE COMMUNITY