Bad PSU or something else?

michaelstocker240

Prominent
Feb 5, 2018
23
0
510
0
For a while I've been having frequent crashes about once a day. My computer completely freezes but stays powered, but when I restart the computer a "Kernel-Power" Event ID: 41 is generated. Some research would lead me to believe this is a problem with my PSU since all of my audio drivers are up to date. But there is another problem... When restarting my computer it will start for about 1 - 2 seconds before completely shutting off again and not turn back on. I checked all of the connections and they are fine. It's only when I take out the power cord and plug it back in that I can turn my computer back on. So this means there is a problem with my PSU or the cord right? But if that's true why does my computer stay powered when the crashes occur? Is this something else? Any responses will be much appreciated as I want to rule out every other option before spending money on new hardware.
 

Sedivy

Estimable
Dec 17, 2016
2,324
0
3,960
497
Event id 41 (63), is a hardware error or issue with drivers for hardware, but it's non-specific so hard to say what's causing it. Here's the checklist:
https://social.technet.microsoft.com/Forums/windows/en-us/308cbcb3-46ce-4f74-85f9-d87ce4cef0d6/kernel-power-event-id-41-task-category-63-spontaneous-improper-shutdowns-and-reboots?forum=w7itproperf
When you've had these crashes for a while and now finally won't booth, yes it could be psu but it could be other things too like your mobo or cpu or even memory. The cord thing in my mind points to discharging of psu capacitors, so yes that would be my suspicion as well. If you have a friend or family member with a computer with approximately similar wattage, you could put their psu in and see if you have the same issue. Mobo would probably be my next best guess but without swapping in components you won't know for sure.
What are your specs?
 

michaelstocker240

Prominent
Feb 5, 2018
23
0
510
0

CPU: AMD FX-8320 overlocked to 4GHz
CPU COOLER: H100i AIO corsair watercooler
MOTHERBOARD: Gigabyte 990XA-UD3 R5
RAM: 16GB DDR3 / 2x8 Kingston sticks
GPU: Nvidia GTX 970
PSU: PC-850AUBA-M (850W)
Windows boot on a 120GB SSD

I'll try using default BIOS settings, disabling overclock and checking memory. But sometimes my computer can go a whole week before encountering this problem again so it is hard to troubleshoot.

 

Sedivy

Estimable
Dec 17, 2016
2,324
0
3,960
497
Yes do work through the checklist. Also check your temps with hwmonitor to rule out overheating.
If unplugging helps, try just shutting down your computer once you're done with it, instead of putting it to sleep or leaving it on. Shut down the switch on the power bar everything's plugged into as well. Might help decrease the frequency of this happening but if it is your psu going, eventually it'll get worse and die on you eventually. If it's the wiring in your place, then shutting it down overnight might help greatly. So just a heads up.
 

michaelstocker240

Prominent
Feb 5, 2018
23
0
510
0

Temperature is definitely not the problem, I've been using HWMonitor for a while to monitor temps and my GPU can get hot under load but i'm having this problem even without me doing much on the PC. I did a memory check and no errors were detected in RAM. I have now reset the BIOS and taken off the overclock. There is one thing I find weird, despite having the clock speed set to 3.5GHz in the BIOS as the default for the CPU, it doesn't drop below 3.7GHz. This is 200MHz higher than usual but according to the BIOS it's running at the default. Not sure if this is a problem but I thought I would say anyway just incase.
 

Sedivy

Estimable
Dec 17, 2016
2,324
0
3,960
497
No it's...some mobos have this turbo feature which will push it up, but that's not a real overclock. Do not worry about it.
Make sure when you were testing memory that you did minimum 8 passes with memtest. You can test your gpu with furmark and cpu with Prime95 though do not do overnight tests. You can also do a combined gpu+cpu which is usually a demanding game.
However I'd probably first test the psu and you can do it yourself https://www.wikihow.com/Check-a-Power-Supply but it's often just easier to put in another psu from a different computer to check.
 

michaelstocker240

Prominent
Feb 5, 2018
23
0
510
0

Ah, good to know. Thanks.
 

Sedivy

Estimable
Dec 17, 2016
2,324
0
3,960
497
When I wrote combined cpu+gpu test I didn't mean run furmark and prime together. I just realized that's how that could be taken. I meant run a demanding game which will pretty much do what you need.
 

michaelstocker240

Prominent
Feb 5, 2018
23
0
510
0

Just loaded my PC today... Even after turning overclock settings off, it crashed seconds after startup.

 

Sedivy

Estimable
Dec 17, 2016
2,324
0
3,960
497
Hmm seconds after startup of the game or startup of the computer?
If former, did you try loading just the cpu with prime 95? Or just the gpu with furmark? Should help isolate which one is the issue. Same with memory.
If unplugging helps, I wonder if your wiring is ok, and you're just having static charge buildup, but...that wouldn't discharge just by briefly unplugging I wouldn't think.
Easiest check for the psu is to just put in another psu in of approximately same wattage that you know works, and see if you can get it to happen after starting a game.
 

michaelstocker240

Prominent
Feb 5, 2018
23
0
510
0

Was talking about seconds after starting up my PC... There seems to be no link between the problem and my computer being under stress, it can happen at any random time like I said. And I don't have a PSU lying around that would be usable. The only option would be to buy a new one. But I want to rule out every possible solution before spending money. Do you think i'm out of options? Should I just buy a new PSU?
 

Sedivy

Estimable
Dec 17, 2016
2,324
0
3,960
497
Not until you've ruled out other things.
Seconds after startup is more concerning. Can you get into windows anymore?
 

turkey3_scratch

Polypheme
Herald
Jul 15, 2014
22,637
0
67,160
2,060
Since you have to unplug the computer and plug it back in to get it work, that is usually a sure sign of a power supply protection kicking in. Plus your PSU is an unknown and likely below average unit. I'm not guaranteeing 100% it's the PSU, but that's what I'd suspect.
 

michaelstocker240

Prominent
Feb 5, 2018
23
0
510
0

I can still get into windows... My point is, the crash can happen at any time, seconds after startup or hours after stressing my PC.
 

michaelstocker240

Prominent
Feb 5, 2018
23
0
510
0

Unknown unit? What do you mean by this? The PSU is stated in a previous comment.
 

Sedivy

Estimable
Dec 17, 2016
2,324
0
3,960
497
You can't reproduce it to happen after running prime95 alone? Or Furmark? or memtest?
If not, try plugging it somewhere else in the house, preferably with a surge protector in between, just in case it is something about wiring.
If none of that helps, then take it into repair shop where they can swap in different components to see at what point instability stops.