Question Bad PSU ?

Mrillegal_

Prominent
May 6, 2020
38
1
545
1
Hey ,
after failing my previous PSU i bought new one when i installed it my HDD and Case fans that i connected them to SATA Socket on PSU got damaged (mean they are not working anymore) . i thought the problem is PSU and sent it to guarantee service , they checked my PSU and they called me there is no problem with your PSU .
im also using surge protector ,can problem be from that?

PC spec :
Mobo : Asus B 450 pro gaming
GPU : MSI rx 5700 xt gaming
CPU : Ryzen 5 3600 x
Ram : 2x 8 gb 3200 mhz Teamgroup Delta
HDD : 2x WD 3.5(They are not working anymore)
PSU :Rog strix 850 w
 

Mrillegal_

Prominent
May 6, 2020
38
1
545
1
Hey ,
after failing my previous PSU i bought new one when i installed it my HDD and Case fans that i connected them to SATA Socket on PSU got damaged (mean they are not working anymore) . i thought the problem is PSU and sent it to guarantee service , they checked my PSU and they called me there is no problem with your PSU .
im also using surge protector ,can problem be from that?

PC spec :
Mobo : Asus B 450 pro gaming
GPU : MSI rx 5700 xt gaming
CPU : Ryzen 5 3600 x
Ram : 2x 8 gb 3200 mhz Teamgroup Delta
HDD : 2x WD 3.5(They are not working anymore)
PSU :Rog strix 850 w
 

Mrillegal_

Prominent
May 6, 2020
38
1
545
1
If you used the CM cable(s) on the Asus good chance what ever that cable was plugged into is now fried. Have you tried using the correct cable?
yes i did for HDD and hdd didnt boot , also i checked hdd on another PC and it seems the HDD fried and damaged.
but still i didnt check the fans with correct cable
 

ASK THE COMMUNITY