Question Battery changing from 0% and not present

Oct 28, 2018
6
0
10
0
So I did up my old Dell latitude 10 and it's alright considering it's old. However I get this message saying "your battery has reached the end of its life and must be replaced" I'm going to order a replacement but I also wondered why the battery info was flickering between 0% and battery not present. Is this the battery? Or a connection or sensor? Does it need to be fixed?
 
Li-ion batteries are very temperamental. If you overcharge them, they can catch fire or explode. If you let their charge drop too low, then attempt to recharge them, they can catch fire or explode. Consequently, manufacturers pair batteries up with protection circuitry which monitors the state of the battery to assure the above two things don't happen.

As a battery gets repeatedly cycled (charged and discharged), (1) its max charge before the overcharge thing happens decreases, and (2) the max Wattage you can pull from it decreases. (2) is the usual failure mode - the battery reports you have plenty of charge left, but then your laptop suddenly shuts off. What happened is the laptop tried to draw more wattage than the worn battery could provide, so it immediately shut off.

Your battery seems to have failed via mode (1). I would guess it's probably flickering between 0% battery and no battery because someone didn't program the indicator very well. And it's measuring zero charge from the battery so reports 0%,. Then it queries the battery health and discovers that the protection circuitry has disabled the battery, and so greys it out. A short time later it repeats this process, resulting in it flickering between 0% and greyed out.

If it bugs you, just remove the battery and run on straight AC until the replacement battery arrives. Actually, that's probably a good idea even if it doesn't bug you. If the indicator was programmed poorly, there's no telling what else was programmed incorrectly in a dead battery state. And the last thing you want is for your laptop to catch fire or explode because it tried to charge the battery even though the battery protection circuitry marked it as dead/don't charge.
 

Similar threads


ASK THE COMMUNITY

TRENDING THREADS