Battery non functioning after recent Windows 10 update

Jul 25, 2018
2
0
10
0
About a month ago I was forced to update Windows 10 on my ASUS P2540UA-AB51. Since then, update my battery has been reading 89% and 42 mins to charge without change over the full month. The laptop also only functions when plugged into its wall charger, it instantly turns off upon disconnection. I'm hopeful it is a software issue with the frozen battery info and that the battery was functioning perfectly right up to the update, and broken right after without being touched during
.
I've done some research and have tried uninstalling and reinstalling the 2 battery drivers, resetting the power scheme, a fresh start through windows defender and tried fully clearing and reinstalling windows (which failed as every time I attempted as I received an error that the PC was not able to reset and returned to normal, also tried 4+ methods to troubleshoot resetting) with no change in the battery issues.

Even though I don't think it is a hardware issue, I tried to find a new battery but was unable to anywhere online. Any suggestions aside from what I have already tried would be greatly appreciated!
 

Colif

Titan
Moderator
have you run Asus live update? its on the drivers page here under utilities - https://www.asus.com/Commercial-Laptops/ASUSPRO-P2540UA/HelpDesk_Download/ as it might be the bios or power management drivers, or another driver.

have you tried it in safe mode to see if it behaves same way there?

did you run dism to fix reset?
right click start button
choose powershell (admin)
copy/paste this command into the window:
Repair-WindowsImage -Online -RestoreHealth and press enter
This fixes the image file that reset uses

how did you clear windows? Fresh install or refresh? If it was only a refresh, could try a fresh install
download the Windows 10 media creation tool and use it to make a win 10 installer on USB
change boot order in BIOS so USB is first, hdd second
boot from installer
follow this guide: http://www.tenforums.com/tutorials/1950-windows-10-clean-install.html

when you reach the screen asking for licence, click "I don't have a key" and win 10 will continue to install and reactivate once finished
 
Jul 25, 2018
2
0
10
0


I tried all three with no luck unfortunately, starting to think it might be a hardware issue actually.
The asus live update fixed the handwriting tool, graphic driver and winflash. I also was able to fully reset and factory reset the PC. The two unfroze the battery reading, now instead of being stuck at 89% it reads 'battery not detected'. The dsim fix completed and read:
Path:
Online: Fals
Image HealthState: Healthy
RestartNeeded: False

I suppose it is possible a surge fried the battery or something else that isn't functioning hardware wise. If you have any other suggestions that would be awesome. Either way, I appreciate you taking the time to help me out!
 
Jul 28, 2018
2
0
20
1
I don't think it is a hardware issue, I tried to find a new battery but was unable to anywhere online. Any suggestions?

Check software you are using

Utorrent
UC Browser
UKTvNow APK

These 3 Softwares use too much battery, I'll recommend you to close the application you're not using. Visit only trustable website,

Search engine - Google

For Solution - TomsHardware

Download something, search on google download only from sites which only appear on frist page for your keyword on google.

For example - you want to download uktvnow

Search - UKTvNow

This site will come on 3rd result visit and download - https://uktvnowz.com/

Google only recommends trusted sites.
 

ASK THE COMMUNITY

TRENDING THREADS