Battlefield 3 FPS drops 7850 2GB

Status
Not open for further replies.

odedgal67

Distinguished
May 31, 2012
61
0
18,630
Hey guys,
So I got the sapphire 7850 2GB with the i5 3450 (not OC but at full load CPU will reach frequencies of 3300 Mhz).
I have had this computer for about a month now and I played BF3 just fine with pretty high graphics at 1920X1080 and didn't have any FPS drops.
Suddenly I am getting some major FPS Drops very often. They are very quick, I mean it drops but then comes up again, but its noticable. The game like gets stuck for a half a second then comes back again to average FPS. I checked the CPU and GPU preformence while playing with the command "render.prefoverlayvisible 1" and I saw that every time I get those drops the GPU and CPU jump out of the chart a lot then come back to normal..... (the chart measures usage of GPU and CPU).
I checked with HWMonitor what is the highest temperature the GPU and CPU gets to and the temp is pretty solid. GPU - 66 Celsius (max temp) CPU - 57 Celsius (max temp)

I just doesnt understand what causes those drops....|

Also I got a 8GB of RAM 1333MHZ and a Blue Caviar 1GB western digital hard disc.
with a very quality 550W PSU.....
Please help me!!
 
very quality PSU, hmm, I never heard of such company...

check your background programs and anti-virus, it's unlikely you game is causing the spikes, which means it's something in the background causing them.

scan for malware, try gamebooster. lastly check your vRAM utilization
 

odedgal67

Distinguished
May 31, 2012
61
0
18,630
Don't be silly... Its a Thermaltake supplier....
And I had nothing working on the background exept the HW Monitor but he isn't the one who caused those spikes because I started using it while playing after the drops started happening.
 

Almin94

Honorable
Jul 10, 2012
52
0
10,630
Hey guys, i have the same problem as odedgal67. How can i fix that? I'm tired and I spent the whole day looking for the fix this problem. Other games work perfectly (Crysis 2-DX11, HiResTextures, Metro2033, Crysis Warhead, Sleeping Dogs..).
I have this problem only with Battlfeild 3 and Medal of Honor Warfighter.

Please help me! :(


MBO: ASUS M4A89GTD PRO/USB3
CPU: AMD Phenom II X4 955BE ~ 4.0GHz (CPU/NB Freq: 2600MHz)
CPU COOLER: Cooler Master V8
GPU: Gigabyte HD6950OC Windforce 3X (Core: 900MHz; Memory: 1470MHz)
RAM: 8GB Kingston HyperX blu. 1600MHz 8-8-8-22
PSU: Thermaltake Toughpower XT 775W
HDD: WD Caviar Black 500GB
MONITOR: Philips 247EL LED
 

Almin94

Honorable
Jul 10, 2012
52
0
10,630
Hey guys, i have the same problem as odedgal67. How can i fix that? I'm tired and I spent the whole day looking for the fix this problem. Other games work perfectly (Crysis 2-DX11, HiResTextures, Metro2033, Crysis Warhead, Sleeping Dogs..).
I have this problem only with Battlfeild 3 and Medal of Honor Warfighter.

Can anyone help me to fix this?
 
Status
Not open for further replies.

TRENDING THREADS