• Pardon our dust as we work on some regularly scheduled forum maintenance. You may notice some missing features during this time. Thank you for your patience!

Question bcdedit problem in a multiboot setup

dictum9

Distinguished
Aug 13, 2008
51
0
18,540
2
The machine is MSI Titan GT80 SLI running Windows 10 1903.

It has 4 SSD disks, two PCIe and 2 SATA. I am only concerned about the PCIe SSD (2280 format). Here is the layout, it's disk 0 and disk 1 that are relevant.





Disk 0 boots just fine.
I cloned disk 0 to disk 1 using Macrium reflect. Then I created the BCDboot entry to create a multiboot operating system. It looks like this. Here is a view through EasyBCD:



and here is the output of bcdedit:




Windows Boot Manager
--------------------
identifier {bootmgr}
description Windows Boot Manager
locale en-US
inherit {globalsettings}
default {current}
resumeobject {34222f3b-2d98-11e9-9e5a-d8cb8aefea8e}
displayorder {d1256220-1323-11e9-8b85-806e6f6e6963}
{bbb9cb4e-6dfd-11e9-9eee-806e6f6e6963}
{bbb9cb4f-6dfd-11e9-9eee-806e6f6e6963}
{bf1f5d80-a0fd-11e9-8b69-806e6f6e6963}
{ef173654-a0f6-11e9-8b6b-806e6f6e6963}
{d1df20ef-1342-11e9-a142-995979db796d}
{current}
{34222f43-2d98-11e9-9e5a-d8cb8aefea8e}
{34222f46-2d98-11e9-9e5a-d8cb8aefea8e}
toolsdisplayorder {memdiag}
timeout 9
displaybootmenu Yes

Firmware Application (101fffff)
-------------------------------
identifier {d1df20ef-1342-11e9-a142-995979db796d}
description Fedora
custom:250000c2 0

Windows Boot Loader
-------------------
identifier {current}
device partition=C:
path \WINDOWS\system32\winload.efi
description Windows 10
locale en-US
inherit {bootloadersettings}
recoverysequence {34222f3e-2d98-11e9-9e5a-d8cb8aefea8e}
displaymessageoverride Recovery
recoveryenabled Yes
isolatedcontext Yes
allowedinmemorysettings 0x15000075
osdevice partition=C:
systemroot \WINDOWS
resumeobject {34222f3b-2d98-11e9-9e5a-d8cb8aefea8e}
nx OptIn
bootmenupolicy Standard

Windows Boot Loader
-------------------
identifier {34222f43-2d98-11e9-9e5a-d8cb8aefea8e}
device partition=L:
path \Windows\system32\winload.efi
description Windows 10 -- 860 M.2
locale en-US
osdevice partition=L:
systemroot \Windows
resumeobject {edea4af9-af54-11e9-9f32-806e6f6e6963}

Windows Boot Loader
-------------------
identifier {34222f46-2d98-11e9-9e5a-d8cb8aefea8e}
device partition=G:
path \Windows\system32\winload.efi
description Windows G:
locale en-US
osdevice partition=G:
systemroot \Windows


After I did the clone, it stopped booting completely. Not even the primary drive is seen. Seems there is a conflict between two drives somehow. I went into BIOS and none of the 4 disks were seen. Furthermore when I hit F11, I could not even boot off the flash drive with Gparted to edit the partitions.

When I removed the primary disk, I could boot into the cloned disk just fine, it's just that they don't work together. I did have to go into BIOS and adjust this. When I get a boot failure with 2 disks installed at the same time, I don't even see the option for Boot Option 1.. et cetera. When I remove either the primary or the clone disk, I get that option back and when I correct add Boot Option 1 pointing to the Samsung MZVxxxx, it boots correctly.




So with 2 disks installed, I don't even see this:



But this is the real question, why do I see this debian entry? I had previously used the disk for Debian install but since reused the disk for Windows clone and it should have retained none of the Linux stuff. The grub bootloader is still on the disk, or is that a conflict in NVRAM, grub is conflicting with bcdedit stuff?

Disk 0 and Disk 1 are identical NVMe/PCIe disks with identical data on them but it can only boot off one if I nuke the EFI System Partition on the other disk, the 100MB sector. Then it boots. I re-run the Macrium Reflect clone/image process several times, copying all of the partitions, and always end up with the same result. I even formatted the disk and re-cloned it off primary, same result.
I cannot multi-boot anymore, and the other disk is just a disk that can be used for data and nothing else. They both boot, just not together.
How do I delete the Linux bootloader entry and where is it located?

It used to multi-boot in that exact BCDEDIT configuration with these exact disks until I got Linux involved.
 

USAFRet

Titan
Moderator
Mar 16, 2013
112,072
1,656
154,940
18,467
Multiple semi bootable clones in the same system...why why why?

The Debian thing could only have come from a previous Linux install attempt.
During your clone or install process, you did not delete that partition. Hence, it still exists.
 

dictum9

Distinguished
Aug 13, 2008
51
0
18,540
2
it's an error in the NVRAM it seems. I have a few ghost entries pertaining to Linux.

I am unable to delete this debian entry which I think might be messing up the whole thing.
I run:

bcdedit /delete {feccce7b-b0ea-11e9-9f43-806e6f6e6963}

but upon the reboot, it comes back.

Firmware Application (101fffff)
-------------------------------
identifier {feccce7b-b0ea-11e9-9f43-806e6f6e6963}
device partition=\Device\HarddiskVolume9
path \EFI\DEBIAN\GRUBX64.EFI
description debian
 

ASK THE COMMUNITY

TRENDING THREADS