Belkin USB n600 Connection Problem

Jun 10, 2018
16
0
10
0
Hi,
So as the title says I’m having trouble trying to get my belkin usb n600 wifi adapter to connect. When I look at the status of the device it says it’s working properly. It appears to be connecting to the wifi, but for some reason it’s saying it’s not connected to my computer, even though it’s plugged in.

I’ve tried uninstalling and reinstalling the drivers, but that didn’t work. It appears the usb is working fine as the lights are on. Does anyone have any idea on what might be the problem?
 

Lutfij

Titan
Moderator
Are you referring to the device not connecting to your wireless network or that you're unable to connect to the broadcast SSID? Might want to share your wireless routers make and model with us. Perhaps you're going to need to update the firmware on the router. Are you on the latest drivers for your wireless adapter(after registering on their site)?

Make sure your chipset/USB drivers are up to date and that your motherboard BIOS is to the latest revision.
 
Jun 10, 2018
16
0
10
0

I guess it’s kind of where the usb wifi adapter is not able to connect to the broadcast SSID. I know there is a wifi signals since my phone and laptop can connect to it. For my pc I’m just prompted that there are no connections available. When I look through my network connections. I can see the belkin usb, even though it’s plugged in, all it says is that it’s not connected, with that red “x”.

The strange thing was that this usb wifi adapter was working fine about a week ago. Recently I just upgraded about everything in my pc, and when I tried to use this usb, this problem began occuring. Before I installed it, I made sure everything was up to date in my pc.
 

ASK THE COMMUNITY

TRENDING THREADS