Question BenQ monitor: DVI-to HDMI no power but DVI-to-DVI works okay ?

frequentweaver

Reputable
Jan 23, 2017
3
0
4,510
0
I have a BenQ RL2755 monitor running off a EVGA GeForce GTX 1060 6GB card. The card was connected to the monitor by a DVI to HDMI cable. A couple of months ago, the monitor's power would begin to flicker off for a second before coming back on. I couldn't figure out the problem, but it didn't happen very often, so I ignored it – not great, I know, but I was busy. Anyhow, a couple of days ago, it started getting significantly worse, shutting off for minutes at a time until the power went off completely. When the monitor is plugged in by itself, the power is fine. The instant I connect it to the monitor, it goes dead. No power light. It's a potato.

I tried replacing the power cord and the DVI-to-HDMI cable. I updated drivers. None of that made a difference.

I don't have a second DVI compatible computer on which to test the monitor, but it works when I hook it up to my laptop with HDMI-to-HDMI cable. It is now working on my tower now that I've connected it DVI-to-DVI. But DVI-to-HDMI still instantly shuts down the monitor's power ?

I'd be grateful for any troubleshooting suggestions.
 

Bentp2019

Commendable
Dec 16, 2019
50
5
1,565
20
So you mean that using the HDMI- DVI will make the monitor auto power-off? That's way too weird, but sounds like the issue is about the chip in the monitor.
 

frequentweaver

Reputable
Jan 23, 2017
3
0
4,510
0
So you mean that using the HDMI- DVI will make the monitor auto power-off? That's way too weird, but sounds like the issue is about the chip in the monitor.
Yes, that's what's happening. I'm now getting some mild flickering with DVI-to-DVI as well. I suspect it may be time to replace the monitor, but I'd like to be sure it's not something I can't fix.
 

ASK THE COMMUNITY