Question BenQ PD2705Q - Usb hub/KVM troubles...

Apr 25, 2021
4
0
10
0
Monitor is plugged into my PC via USB & Display port, a second monitor is connected via Display port, and laptop is connected to monitor via USB-C. If I plug my mouse/keyboard/webcam into the monitors usb ports they work fine on the laptop, but not at all on the desktop connected to the same screen. I've tried using a different USB A to B cable other than the one that came with it but same results. Is there some kind of setting I'm missing on my desktop? I've installed all the relevant drivers on both pc and laptop.

Not sure if I am missing something blindingly obvious or not?!
 

Bentp2019

Prominent
Dec 16, 2019
47
5
565
18
"a second monitor is connected via Display port", So you connect your monitor1 and monitor 2 with a DP cable, right? Then which monitor you connect your USB peripherals to? Monitor1(the one you have your PC connected with) or monitor2. And which monitor you connect to your laptop to.

Here's my guess, the laptop's USB-C connects to monitor 2, and that's where the USB peripherals are. And the PC is connected to monitor1. In this case, the data from USB peripherals can't get past through the DP cable between the monitors.
Please correct me if I misunderstood.
 
Apr 25, 2021
4
0
10
0
On the OSD the KVM Switch menu is completely greyed out so I can't access any of the settings for it. It's like it's been disabled somehow.
 

Bentp2019

Prominent
Dec 16, 2019
47
5
565
18
How about having the KVM set properly and then enable the MST. I think you can control the KVM by switching the input source and having the MST simultaneously.
 

ASK THE COMMUNITY