Best driver for sapphire x1950 pro agp 512mb???

nizar92

Distinguished
Mar 1, 2010
7
0
18,510
0
hello!:hello: i checked for alot of drivers for my sapphire x1950 pro agp 512mb but non works perfectly:( :sweat: plz help!!!!!!!!!!!!!!! THANKS:D
 

jaguarskx

Titan
Moderator
Apr 19, 2006
27,979
0
97,160
4,082
I believe the last driver which supports the Radeon X1xxx series is Catalyst 9.3.
 

sturm

Splendid
Apr 1, 2002
3,829
0
22,960
90
I would start with the drivers that are on the cd that came with the card. Then look at the updates and see if they deal with your card. I would only update the driver if it solves a problem with your card. Being that it's agp I doubt the newest drivers would make any difference, if not even make things worse.
I have an x1950 agp. I'll check drivers when I get home from work.
 

nizar92

Distinguished
Mar 1, 2010
7
0
18,510
0
i tried the drivers on the cd but during playing fifa 10 and fallout 3 many glitches even under low resolution and video quality.i'll try now the catalyst 9.3 but is there any other modified driver?thanks guysssss:)
 

sturm

Splendid
Apr 1, 2002
3,829
0
22,960
90
Checked my system that is running just fine on an HD4850.
Driver Date - 11/24/2009
Driver Version - 8.861.0.0
Catalyst version - 09.12

So far runs everything perfect.
 

sturm

Splendid
Apr 1, 2002
3,829
0
22,960
90
It wouldn't let me change my previous message

I am running windows 7 64-bit.
 

nizar92

Distinguished
Mar 1, 2010
7
0
18,510
0
many glitches in playing games even under low quality and low resolution...:( plz help!:'(
 

sturm

Splendid
Apr 1, 2002
3,829
0
22,960
90
So what kind of glitches are you having? weird polygons on the screen, lines on the screen, choppy video?
Have you tested your system memory yet with say prime 95?
What are your temps running? Is the graphics card overclocked at all?
 

nforce4max

Judicious
Sep 9, 2009
8,336
0
32,160
301
9.3 is the best that you can get for these older ATI cards that work properly and are what I use with my x1900xt.
 
G

Guest

Guest




Hi I am getting weird polygons on screen in Sup Com 2, worked find when i had vista 32bit. Now am running Windows 7 64bit.

Any help would be greatly recieved.

Cheers
 

nforce4max

Judicious
Sep 9, 2009
8,336
0
32,160
301
Hi I am getting weird polygons on screen in Sup Com 2, worked find when i had vista 32bit. Now am running Windows 7 64bit.

Any help would be greatly recieved.

Cheers

Wow that is very little info one can get more by looking into a crystal ball. :sarcastic:
 
G

Guest

Guest
:p
I will try again,
I have shapphire x1950pro PCIe 512
Running Win 7 64bit ultimate.
MB = Asus p5k premium
Ram = 2GB of crossiar (looking too increase ram soon = reason 64 bit.)
CPU =quad core q6600 intel.

Had same set-up before, all same hardware, but was running vista 32bit buisness, game work fine on this set-up.

Did a fresh install of win 7 ultimate 64bit, downloaded latest drives for x1950 pro, tryed 9.1 and latest version 10.2 vista 64bit. none worked.

Game loads up menus fine, can change grpahic options in game, everything seems fine.
But when games loads, map looks fine but crazy polygons seem to stretch and flicker about the screen. making it nearly impossible to play.

Cheers
 

sturm

Splendid
Apr 1, 2002
3,829
0
22,960
90
Have you tried running the game in vista or xp compatibility mode?
 

nforce4max

Judicious
Sep 9, 2009
8,336
0
32,160
301
:p
I will try again,
I have shapphire x1950pro PCIe 512
Running Win 7 64bit ultimate.
MB = Asus p5k premium
Ram = 2GB of crossiar (looking too increase ram soon = reason 64 bit.)
CPU =quad core q6600 intel.

Had same set-up before, all same hardware, but was running vista 32bit buisness, game work fine on this set-up.

Did a fresh install of win 7 ultimate 64bit, downloaded latest drives for x1950 pro, tryed 9.1 and latest version 10.2 vista 64bit. none worked.

Game loads up menus fine, can change grpahic options in game, everything seems fine.
But when games loads, map looks fine but crazy polygons seem to stretch and flicker about the screen. making it nearly impossible to play.

Cheers

That right there is artifacting and is the result of heat. turn up the fanspeed and very little or no improvement clean the dust out of their cooler.
 

nizar92

Distinguished
Mar 1, 2010
7
0
18,510
0
choppy video and many slow response i will install the 9.3 with its catalyst but i dont think this will help other ideas??how about optimized drivers?
 

Similar threads