[SOLVED] Better PC running worse than mine?

Ironarmygeneral

Distinguished
Jan 21, 2015
305
2
18,815
20
Hi guys. I'm not sure if this is the right thread for this. If not, I can move it.

Anyway, so my boyfriend and I both have decent PCs. We both game, but he does a LOT more than I do.

He decided to launch a modpack (Vault Hunters Official), and his performance was completely tanked. Constantly less than 10 FPS. (P.S. the only thing that made it any better was adding optifine, and turning on smart animations). His system consists of: Ryzen 5 2600, RX 580 8GB, and 16GB RAM (I believe 2666MHz). He is running on a 1080p monitor at 60Hz.

I however, tried it myself to see the difference on my PC, and it was MUCH better. My CPU and RAM is better than his, however my graphics card is a GTX 960 2GB and getting to the end of its life quite honestly. (My CPU is a Ryzen 5 5600x, and my RAM is Corsair Vengeance RGB Pro 3000MHz, 32GB, as I have a lot heavier workloads when not gaming than he does).

When I launched the same modpack, and set it to use the exact same settings (minus optifine), I was consistantly getting over 200+ FPS. I know Minecraft is typically "more CPU intensive" but his CPU is still pretty decent and I would think (it's my old one that I gave to him and rebuilt for him) from my experience that it shouldn't be hindering his performance that much.

So, I started monitoring our performance/part usage in task manager just to give me a good idea of what was going on... for me, I was using about 20% CPU, 5GB of RAM, and my graphics card was peaking around 40-50% utilization.

HIS however, was using 20-30% CPU, over 10GB of RAM (made me worried it was cutting into his virtual memory and causing it, still unsure) which is double what mine was taking up, and around 70-80% GPU usage.

Is there anything that stands out that is an almost definite cause of this, or should I just start diagnosing? He has always had performance issues with modpacks, and I have not, even when I had the exact CPU he has (before I upgraded and gave that one to him.)

This is one of the very few games that we BOTH like playing together and it makes for a terrible experience when one of us literally can't even jump let alone walk around. His performance reminded me of 2012-2013 playing MC for the first time on a potato HP laptop and having more like "seconds per frame" rather than "frames per second". Lol.

Anyway. This is nothing major because he is able to at least have it playable with optifine and turning smart animations on, but it's more out of curiosity because obviously something has to be going on. To me personally, it seems more like an entirely separate issue, like a power setting somewhere or some other settings somewhere. Oh and by the way, both of us have latest stable drivers, I already checked
 

Karadjgne

Titan
Ambassador
Superior hardware, yes. But not 100fps superior and he has to use accelerators to help with the same mod pack, while Op has a small network running, and tons of Chrome tabs open, which is very memory intensive in comparison.

If he's only using 10Gb of ram, he's got plenty of room left with 16Gb. Pagefile won't be an issue yet. But 10fps without those accelerators isn't a 2600 vs 5600x issue. There's either something in bios or windows that he has enabled/disabled that Op does not, or something else is going on to cause the kind of memory discrepancy.
 

Karadjgne

Titan
Ambassador
You are assuming it's a hardware issue. It most likely isn't. The single most common cause of unplayable fps or other anomalies when dealing with any sort of mod is conflicts. Doesn't even have to be the mods themselves, as evident on your pc, it's generally something to do with load order or addressing.

Figure out exactly what mods are run on your game, compared to his. What extras he has is most likely the suspect, he can try uninstalling those 1 at a time until his game clears up. If that fails, he's most likely got a corrupted mod, one that's overwritten part of the new modpack, and may need reinstalling to overwrite the corrupted code.
 

Ironarmygeneral

Distinguished
Jan 21, 2015
305
2
18,815
20
You are assuming it's a hardware issue. It most likely isn't. The single most common cause of unplayable fps or other anomalies when dealing with any sort of mod is conflicts. Doesn't even have to be the mods themselves, as evident on your pc, it's generally something to do with load order or addressing.

Figure out exactly what mods are run on your game, compared to his. What extras he has is most likely the suspect, he can try uninstalling those 1 at a time until his game clears up. If that fails, he's most likely got a corrupted mod, one that's overwritten part of the new modpack, and may need reinstalling to overwrite the corrupted code.
Already went through the mods list. Besides optifine (which was running like crap beforehand)

It's an official modpack that we have the same version on, and literally everything about it is exactly the same. I quite honestly don't think it's that, considering he's always had issues playing modpacks when he really shouldn't, at least for most of them. But I did check just to be 100% sure. (BTW this is running on a new install of this version of the game and a completely separate install location, as it's from the Curseforge application which sets modpack and Forge directories separate from your typical location where .minecraft is located).

Also, I did state that I didn't believe it was a hardware issue, and that I thought maybe it was a setting somewhere, or something else. Maybe it is something with the modpack itself but it just seems very unlikely considering there is no difference between my install and his, nor the methods for install, and there were no previous modpacks played on either of our installs of this particular pack. Not to say that when his installed or tried loading the mods, something wonky didn't happen though. I just find it unlikely in our situation
 

Karadjgne

Titan
Ambassador
What's missing then. Are there any requirements for the mod? Things like .Net of a specific version? Is Antivirus interfering? Have you checked task manager during game play on both to see what services are running on his that are sucking the life out of the cpu? Is Xbox DVR and game helper stuff turned off on his in windows?
 

Ironarmygeneral

Distinguished
Jan 21, 2015
305
2
18,815
20
What's missing then. Are there any requirements for the mod? Things like .Net of a specific version? Is Antivirus interfering? Have you checked task manager during game play on both to see what services are running on his that are sucking the life out of the cpu? Is Xbox DVR and game helper stuff turned off on his in windows?
I don't think it would be any of that. When he plays modpacks (especially one so memory intensive) he has nothing else running but the game. Meanwhile I'm running a small bungeecord network, a ton of chrome tabs, steam, discord, Telegram, and a bunch of small miscellaneous things in the background like the DAW I use and still get better performance than him. Oh and on his, literally nothing else (that matters at least, or would suck a lot of CPU/RAM usage)

As far as requirements, everything that would be required is up to date, and pretty much the exact same between my PC and his.

Antivirus... neither of us really use any, (whether or not we should is a different issue), we both are pretty intelligent when it comes to the web and myself when it comes to tech (not always otherwise I wouldn't be posting here) and for us, 99% of the time, Windows Security is enough. Although we did try turning it/firewall on/off and changing different settings to no avail.

What gets me as well, is that, since he has installed optifine on his install of this modpack, and turned ON "smart animations" (which only loads animations in the render area of the screen/display), he is actually getting decent performance, up to 100FPS (vsync off). Still not as much as I am getting but THAT part I think is where the difference between my CPU and his comes into play, regardless of whether the main issue is hardware related or not.
 

Karadjgne

Titan
Ambassador
Superior hardware, yes. But not 100fps superior and he has to use accelerators to help with the same mod pack, while Op has a small network running, and tons of Chrome tabs open, which is very memory intensive in comparison.

If he's only using 10Gb of ram, he's got plenty of room left with 16Gb. Pagefile won't be an issue yet. But 10fps without those accelerators isn't a 2600 vs 5600x issue. There's either something in bios or windows that he has enabled/disabled that Op does not, or something else is going on to cause the kind of memory discrepancy.
 

ASK THE COMMUNITY

TRENDING THREADS