BF4 32Bit low Graphics

andy_93

Distinguished
Dec 11, 2009
593
0
19,010
10
Hi all, just installed BF4 and go into settings and graphics are locked to low. It say that graphics cannot be adjusted on a 32bit o/s. The thing is, i am running windows 7 64bit but still cannot adjust graphic settings. Is anyone else having this problem, or know how to fix it please.
Many thanks
Andy
 

andy_93

Distinguished
Dec 11, 2009
593
0
19,010
10
Hi, my specs are
8 gig ram
Sapphire 7950 oc edition
Intel Core i5 @4.3 Ghz
Windows 7 64 bit.
I know its not the best rig going but I should be able to at least adjust the graphics settings to at least medium/high. Maybe not max.
Hope this helps
Thank you
 

Disticord

Honorable
Nov 3, 2013
1
0
10,510
0
I have the exact same problem LOL and EA technical support is a joke.

Intel I7 950 overclocked to 3.5
GTX680 4gb FTW edition
16gb of Ram

I was able to play on max settings up until 2 days ago when it updated my microsoft visual c++ but now I can't fix it at all ~ I get consistent errors.
 
sounds like a directx issue. M$ has been supporting BF4 for win 8.1, and as a result the experience of people with win7 is markedly lower right now. you're likely running into one of the many issues win7 users are experiencing since bf4 works better with directx 11.2
 

Wollfenburg

Honorable
Nov 4, 2013
1
0
10,510
0
Same problem. My friend suggested I run BF4 on X86 instead of X64 because it was more stable, and it was. BUT that locked my graphics on low. I changed my game back to X64 and I can choose my graphics settings now. Right click the game in Origin > Show Game Details > Edit Launch Options and choose X64. X64 may be less stable and crash prone, but it seems to let me play on High. I have a GTX 560ti btw
 

h2k47

Distinguished
Apr 6, 2009
33
0
18,530
0
To change graphics settings in BF4:


1- open up PROFSAVE_profile using notepad which is found in 'C:\ Users\...\ MyDocuments\ Battlefield 4 \ settings '

2- set the 'OverallGraphicsQuality' to 5 and save.(this will set graphics to custome)

 

deltayuri101

Honorable
Sep 29, 2013
85
0
10,640
1
right click on bf4 in origin then click game properties. there will be a drop down on the top that says "present all options" click the drop down and click "Battlefield 4 x64" hope that helped!
 

MoralShock

Reputable
Aug 6, 2014
1
0
4,510
0


OMG you saved me 300 Dollars!!! Let me get your steam username and I will hook u up!! I been trying to find a solution for months and I was about to buy a new video card!! EA was sure no help at all, I also hope this helps my direct x error issues!
 

Similar threads


ASK THE COMMUNITY