Question Bios 5 beeps but PC works

rounakr94

Distinguished
Jul 28, 2013
1,569
12
20,165
164
Hi,
I was cleaning my PC and I forgot to plug in the Display port cable to my GPU.
When I turned on PC it gave 5 beeps followed by a small post successful beep. I then hurriedly plugged in the DP cable and I was greeted with the Windows login screen.

So why the 5beeps, GPU was already plugged into motherboard and power cable was connected only I missed out on the DP cable. Can the bios detect if gpu has something plugged in the I/O ports or not and maybe warned me that connect the cable?


My GPU is a msi 6600xt and cpu is r5 3600.
 

rounakr94

Distinguished
Jul 28, 2013
1,569
12
20,165
164
So why the 5beeps, GPU was already plugged into motherboard and power cable was connected only I missed out on the DP cable. Can the bios detect if gpu has something plugged in the I/O ports or not and maybe warned me that connect the cable?
you don't have igpu
Hi please read what I quoted.
The gpu is connected and power plugged in only display port cable was not connected.
 

rounakr94

Distinguished
Jul 28, 2013
1,569
12
20,165
164
computer is smart enough to know if you have video cable plug in to the motherboard and not the gpu
NVM, found it in the Asrock forums that its normal for Asrock bios to beep 5 times as a warning when GPU doesn't have anything connected in its I/O. This holds true as system boots up normally with bios post beep after the initial 5 beeps.
 

ASK THE COMMUNITY

TRENDING THREADS