Question BIOS and Windows are not recognizing Samsung 970 Evo Plus NVMe M.2 SSD

Dec 4, 2019
1
0
10
0
I'm sorry, but I've been searching these forums, Youtube, and Google for hours now and I'm about to go insane because I know very little about making changes to computer build.

I recently bought a Samsung 970 Evo Plus NVMe M.2 2TB SSD. I followed a Youtube tutorial to plug it into my MSi Meg Z390 ACE motherboard using the M.2_1 slot. My original Samsung 970 Evo Plus NVMe M.2 1TB SSD is plugged into the M.2_2 slot.

After dropping the teeny-tiny screw that was made for ants while trying to install my second SSD and just about losing my mind trying to find it as it rolled around in the case, I was able to screw it in successfully. (Recommendation for anyone who is about to install their own SSD: Use one of those nifty little magnetic screwdrivers like I should've done.)

Still following the Youtube tutorial, I went into my BIOS setup - but I only saw the existing 1TB SSD currently in use.

I checked Disk Management, but my new SSD doesn't appear there either.

I didn't plug in any additional cords to my motherboard, but from what I've been seeing in my forum/YT hunting - no other cords need to be plugged in?

There is a helpful little guide in the user manual for my motherboard, but since my SSDs are plugged into M2_1 and M2_2 then I don't think I'm running into an issue here?

View: https://imgur.com/hXNDtX4


So far I've tried updating the Samsung NVMe Controller, scanning for hardware changes in Device Manager, checking for updated drivers, re-scanning disks in Disk Management, and I've tried looking up changes to make to the BIOS but what I've found so far is typically for other motherboards and mine doesn't have the same options. Maybe something needs to be changed or enabled?

I recently saw a post recommending to reset my CMOS, but I haven't tried that yet.

Any thoughts? Please just let me know if any other information would be helpful.

Motherboard: MSi Meg Z390 ACE
Existing SSD in Slot M2_2: Samsung 970 Evo Plus NVMe M.2 1TB
New SSD I put in Slot M2_1: Samsung 970 Evo Plus NVMe M.2 2TB
 

DMAN999

Estimable
Herald
According to the specs for your MB, it has 3 m.2 slots:
https://www.msi.com/Motherboard/MEG-Z390-ACE/Specification
Intel® Z390 Chipset
  • 6 x SATA 6Gb/s ports
  • 3 x M.2 slot (Key M)
    • M2_1 supports up to PCIe 3.0 x4 and SATA 6Gb/s, 2242/ 2260/ 2280/ 22110 storage device
    • M2_2 supports up to PCIe 3.0 x4 and SATA 6Gb/s, 2242/ 2260/ 2280 storage devices
    • M2_3 supports up to PCIe 3.0 x4, 2242/ 2260/ 2280 storage device
    • Intel® Optane™ Memory Ready
  1. M.2 slots and SATA ports share the bandwidth.
  2. Before using Intel® Optane™ memory modules, please ensure that you have updated the drivers and BIOS to the latest version from MSI website.
From what I see stated here, you might need to try slots M2_1 and M2_3 for nvme ssds.
And I would update the BIOS to the newest version just to be sure it isn't a BIOS related issue:
https://www.msi.com/Motherboard/support/MEG-Z390-ACE
 

ASK THE COMMUNITY

TRENDING THREADS