Question Bios boot issue.

May 9, 2022
4
0
10
0
I'm new to building PCs. This is the first time I've encountered this issue.

I'm trying to enter my bios with the Del key, and nothing happens. I get the initial startup screen but nothing further when I mash Del. Is it supposed to take awhile? I've already checked the motherboard battery, and double checked the m.2 connection. Just curious if there are any other solutions.

Thanks for your help!

UPDATE I managed to get to the Bios Screen! I actually removed the motherboard battery and then held down the power button to reset the Bios (as recommended by another forum). Thanks your help, much appreciated!
 
Last edited:

Lafong

Respectable
2 ways:

Reboot and look for an onscreen text message early in the process. On my PC it says to use Delete key or F2 to enter the BIOS.

Look in motherboard manual or google for it. It varies by motherboard brand/model.
 
May 9, 2022
4
0
10
0
Ok so holding it down seemed to work as I’m getting the “Entering Setup” message, though it’s been on this for awhile. Generally it doesn’t feel like it take this long, is it possible something else is causing an issue?
 

Lafong

Respectable
Ok so holding it down seemed to work as I’m getting the “Entering Setup” message, though it’s been on this for awhile. Generally it doesn’t feel like it take this long, is it possible something else is causing an issue?
It should be very quickly....a second or two.

Post a complete list of your components.

Brand name, model, size, etc.

Is everything new and unused?

Does this machine work OK, other than getting into the BIOS?

What are your intentions in the BIOS? I assume you've never looked at it?
 

dwd999

Honorable
I'm new to building PCs. This is the first time I've encountered this issue.

I'm trying to enter my bios with the Del key, and nothing happens. I get the initial startup screen but nothing further when I mash Del. Is it supposed to take awhile? I've already checked the motherboard battery, and double checked the m.2 connection. Just curious if there are any other solutions.

Thanks for your help!
Did you try removing the m.2 and all other drives? Is the m.2 blank or is there something on it which is interfering with the boot process?
 
May 9, 2022
4
0
10
0
Did you try removing the m.2 and all other drives? Is the m.2 blank or is there something on it which is interfering with the boot process?
The m.2 is blank. I have no other drives connected. I let the computer sit on the "entering setup" screen for awhile and it seemed to have frozen there.
 
May 9, 2022
4
0
10
0
It should be very quickly....a second or two.

Post a complete list of your components.

Brand name, model, size, etc.

Is everything new and unused?

Does this machine work OK, other than getting into the BIOS?

What are your intentions in the BIOS? I assume you've never looked at it?
A complete parts list:
  • Aorus B550 Elite V2
  • 2 8gb sticks Corsair Vengeance LPX
  • RTX 3060
  • Samsung 970 evo plus 1tb m.2
  • Corsair rm750x 750 watt power supply
I have an HDD that isn't connected yet as I was just trying boot the thing to Bios to make sure it could read all the attached parts.
 

ASK THE COMMUNITY

TRENDING THREADS