Question BIOS boots up but options are invisible?? (Intel DQ670W)

Mar 27, 2020
1
0
10
0
Please help, my problem is basically what the title states already

Not a long time ago I bought an used motherboard with an Intel processor and I wanted to put a GPU on it, but it didn't seem to recognize it at first so I figured I needed to update the BIOS, which I did and the problem got solved, could boot up to Windows with my GPU working without a problem

Problem is, I do believe It was after that update (I doubt it was before because I wouldn't been able to update) that my BIOS seems to have got corrupted or something similar... I can boot up and pressing F2 brings me to the BIOS screen, but it looks like everything is invisible! I can navigate through options but there's nothing written on hem... And I'm not sure what to do anymore

I tried booting up without USBs or hard drives connected, and I tried taking out the battery in the motherboard to "reset" the BIOS but it didn't help at all... Here's some images of how it looks

https://ibb.co/rbGm5qh

https://ibb.co/8N8p5Nc

My motherboard is an Intel DQ670W (Cougar Point), which has discontinued support from Intel btw

And my GPU if needed is a Radeon RX560

Appreciate it :)
 

ASK THE COMMUNITY

TRENDING THREADS